{"answers":{"affected":"2 open source packages ship an affected version, including apostrophe.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53609 exists.","fix":"Upgrade apostrophe to 4.31.0 or later.","what":"CVE-2026-53609 is a critical authentication bypass vulnerability in apostrophecms apostrophe, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53609 and fix it if it is affected.\n\nWhat it is: CVE-2026-53609 is a critical authentication bypass vulnerability in apostrophecms apostrophe, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53609 exists.\n\nAffected packages and fixed versions:\n- apostrophe (npm): affected all versions; fixed in 4.31.0\n- apostrophe (npm): affected all versions; fixed in 4.31.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53609/ (Markdown: https://insights.sbomify.com/CVE-2026-53609/index.md)","id":"CVE-2026-53609","markdown":"https://insights.sbomify.com/CVE-2026-53609/index.md","name":"CVE-2026-53609","record":{"aliases":["GHSA-6h5j-32cf-4253"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["security_bypass","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js CMS","requires_auth":"low_privilege","summary":"An authenticated editor can pollute the prototype to bypass authorization checks on all piece-type REST API endpoints for subsequent unauthenticated requests.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"ApostropheCMS is an open-source Node.js content management system. In versions up to and including 4.30.0, `apos.util.set()` traverses dot-notation paths without sanitizing `__proto__`, allowing an authenticated editor to write arbitrary values to `Object.prototype` via the `$pullAll` patch operator. A confirmed gadget in `publicApiCheck()` causes this to bypass authorization on all piece-type REST API endpoints for every subsequent unauthenticated request, for the lifetime of the Node.js process. As of time of publication, no known patched versions are available.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Apostrophe has Server-Side Prototype Pollution in apos.util.set via patch operators that leads to process-wide authorization bypass","id":"CVE-2026-53609","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"GLPI: Reflected XSS in dashboards","id":"CVE-2026-53610"},"packages":[{"ecosystem":"npm","fixed":["4.31.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":null,"source":"GHSA-6h5j-32cf-4253"},{"ecosystem":"npm","fixed":["4.31.0"],"introduced":["0"],"last_affected":[],"package":"apostrophe","purl":"pkg:npm/apostrophe","source":"GHSA-6h5j-32cf-4253"}],"prev":{"headline":"@apostrophecms/seo Vulnerable to Stored XSS via Unsanitized Google Analytics / GTM ID Injected into Script Tag","id":"CVE-2026-53608"},"products":["apostrophe"],"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-15","vendors":["apostrophecms"]},"summary":"An authenticated editor can pollute the prototype to bypass authorization checks on all piece-type REST API endpoints for subsequent unauthenticated requests.","url":"https://insights.sbomify.com/CVE-2026-53609/"}