# CVE-2026-53609: Apostrophe has Server-Side Prototype Pollution in apos.util.set via patch operators that leads to process-wide authorization bypass

> An authenticated editor can pollute the prototype to bypass authorization checks on all piece-type REST API endpoints for subsequent unauthenticated requests.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 15 Jun 2026
- **Also known as:** GHSA-6h5j-32cf-4253

## What is CVE-2026-53609?

CVE-2026-53609 is a critical authentication bypass vulnerability in apostrophecms apostrophe, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ApostropheCMS is an open-source Node.js content management system. In versions up to and including 4.30.0, `apos.util.set()` traverses dot-notation paths without sanitizing `__proto__`, allowing an authenticated editor to write arbitrary values to `Object.prototype` via the `$pullAll` patch operator. A confirmed gadget in `publicApiCheck()` causes this to bypass authorization on all piece-type REST API endpoints for every subsequent unauthenticated request, for the lifetime of the Node.js process. As of time of publication, no known patched versions are available.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-53609?

2 open source packages ship an affected version, including apostrophe.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.31.0 |
| `apostrophe` | npm | All versions | 4.31.0 |

## How do I fix CVE-2026-53609?

Upgrade apostrophe to 4.31.0 or later.

## Is CVE-2026-53609 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53609 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53609 and fix it if it is affected.

What it is: CVE-2026-53609 is a critical authentication bypass vulnerability in apostrophecms apostrophe, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53609 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.31.0
- apostrophe (npm): affected all versions; fixed in 4.31.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53609/ (Markdown: https://insights.sbomify.com/CVE-2026-53609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53609
- OSV: https://osv.dev/vulnerability/CVE-2026-53609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53609/
Summaries are generated and may contain mistakes; the official description above is the record.
