# CVE-2026-53612: util-linux mount hook_owner TOCTOU allows local privilege escalation

> Local attackers can exploit a race condition in the SUID mount utility to escalate privileges to root via fstab options.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2026-53612, AZL-108558, BELL-CVE-2026-53612, DEBIAN-CVE-2026-53612, ECHO-86fa-8a7d-d92b, GHSA-g8wm-75wr-g2vh, UBUNTU-CVE-2026-53612

## What is CVE-2026-53612?

CVE-2026-53612 is a high-severity vulnerability in util-linux, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

util-linux is a random collection of Linux utilities. In util-linux 2.39 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility's `hook_owner.c` post-mount hook performs path-based `chmod()` and `lchown()` operations on a previously validated mount target. A local low-privileged user authorized by an `/etc/fstab` entry with `user` or `users` and an `X-mount.mode`, `X-mount.owner`, or `X-mount.group` option can use `renameat2(RENAME_EXCHANGE)` to race a writable ancestor of the target and redirect the privileged ownership or mode change to a root-owned path, potentially gaining root privileges. This issue is fixed in 2.41.5 and 2.42.2.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-53612?


## How do I fix CVE-2026-53612?

Upgrade to a fixed version.

## Is CVE-2026-53612 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53612 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53612 and fix it if it is affected.

What it is: CVE-2026-53612 is a high-severity vulnerability in util-linux, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53612 exists.

Affected product: util-linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53612/ (Markdown: https://insights.sbomify.com/CVE-2026-53612/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53612
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53612
- OSV: https://osv.dev/vulnerability/CVE-2026-53612

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53612/
Summaries are generated and may contain mistakes; the official description above is the record.
