{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-53614 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-53614 is a high-severity vulnerability in util-linux, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53614 and fix it if it is affected.\n\nWhat it is: CVE-2026-53614 is a high-severity vulnerability in util-linux, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-53614 in the wild and no public exploit code.\n\nAffected product: util-linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53614/ (Markdown: https://insights.sbomify.com/CVE-2026-53614/index.md)","id":"CVE-2026-53614","markdown":"https://insights.sbomify.com/CVE-2026-53614/index.md","name":"CVE-2026-53614","record":{"aliases":["ALPINE-CVE-2026-53614","AZL-109812","BELL-CVE-2026-53614","DEBIAN-CVE-2026-53614","ECHO-6f2b-d2b2-d50c","GHSA-67r7-8m5w-22wx","UBUNTU-CVE-2026-53614"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Linux mount utility","requires_auth":"low_privilege","summary":"Local attackers can bypass nosuid/noexec protections via a race condition in the mount utility to execute SUID binaries and gain root privileges.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-807","name":"Reliance on Untrusted Inputs in a Security Decision"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"util-linux is a random collection of Linux utilities. In util-linux 2.39.1 through 2.41.4 and 2.42 through 2.42.1, the SUID `mount` utility reads the attacker-controlled `LIBMOUNT_FORCE_MOUNT2` environment variable with `getenv()`, allowing a local low-privileged\nuser to force the non-atomic legacy bind-mount path. With an `/etc/fstab` bind mount authorized by `user` or `users` and protected by `nosuid`, `noexec`, or `nodev`, an attacker can race the window between the initial bind mount and the remount that applies those security flags and execute a SUID program from the temporarily unprotected mount, potentially gaining root privileges. This issue is fixed in 2.41.5 and 2.42.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"util-linux LIBMOUNT_FORCE_MOUNT2 allows nosuid and noexec bypass","id":"CVE-2026-53614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"race_condition","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"util-linux libblkid DOS extended-partition overflow produces invalid partition metadata","id":"CVE-2026-53615"},"packages":[],"prev":{"headline":"util-linux mount target TOCTOU allows local privilege escalation","id":"CVE-2026-53613"},"products":["util-linux"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["util-linux"]},"summary":"Local attackers can bypass nosuid/noexec protections via a race condition in the mount utility to execute SUID binaries and gain root privileges.","url":"https://insights.sbomify.com/CVE-2026-53614/"}