{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-53615 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-53615 is a high-severity vulnerability in util-linux, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53615 and fix it if it is affected.\n\nWhat it is: CVE-2026-53615 is a high-severity vulnerability in util-linux, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-53615 in the wild and no public exploit code.\n\nAffected product: util-linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53615/ (Markdown: https://insights.sbomify.com/CVE-2026-53615/index.md)","id":"CVE-2026-53615","markdown":"https://insights.sbomify.com/CVE-2026-53615/index.md","name":"CVE-2026-53615","record":{"aliases":["AZL-108198","BELL-CVE-2026-53615","DEBIAN-CVE-2026-53615","ECHO-9838-e255-038e","GHSA-h4rw-gv36-wmp5","OESA-2026-4576","OESA-2026-4577","OESA-2026-4578","OESA-2026-4579","ROOT-OS-DEBIAN-11-CVE-2026-53615","ROOT-OS-DEBIAN-12-CVE-2026-53615","ROOT-OS-DEBIAN-13-CVE-2026-53615","UBUNTU-CVE-2026-53615"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux utility library","requires_auth":"none","summary":"A local attacker can craft a disk image to trigger an integer overflow in libblkid, causing invalid partition metadata and potential system instability.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"util-linux is a random collection of Linux utilities. Before util-linux 2.41.4, `parse_dos_extended()` in `libblkid/src/partitions/dos.c` computes an extended-partition start sector with 32-bit addition and does not apply the extended-area bounds checks to the first two EBR entries. A local attacker who causes a crafted DOS extended-partition disk image or removable medium to be probed can wrap `cur_start + start` to sector zero and cause libblkid to report a false partition overlapping the MBR. This directly compromises the integrity of the reported partition metadata; disk modification or availability loss requires a separate downstream consumer to act on that metadata. This issue is fixed in 2.41.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"util-linux libblkid DOS extended-partition overflow produces invalid partition metadata","id":"CVE-2026-53615","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"Missing authorization in GROWI","id":"CVE-2026-53620"},"packages":[],"prev":{"headline":"util-linux LIBMOUNT_FORCE_MOUNT2 allows nosuid and noexec bypass","id":"CVE-2026-53614"},"products":["util-linux"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["util-linux"]},"summary":"A local attacker can craft a disk image to trigger an integer overflow in libblkid, causing invalid partition metadata and potential system instability.","url":"https://insights.sbomify.com/CVE-2026-53615/"}