# CVE-2026-53615: util-linux libblkid DOS extended-partition overflow produces invalid partition metadata

> A local attacker can craft a disk image to trigger an integer overflow in libblkid, causing invalid partition metadata and potential system instability.

- **Severity:** High 8.0 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** AZL-108198, BELL-CVE-2026-53615, DEBIAN-CVE-2026-53615, ECHO-9838-e255-038e, GHSA-h4rw-gv36-wmp5, OESA-2026-4576, OESA-2026-4577, OESA-2026-4578, OESA-2026-4579, ROOT-OS-DEBIAN-11-CVE-2026-53615, ROOT-OS-DEBIAN-12-CVE-2026-53615, ROOT-OS-DEBIAN-13-CVE-2026-53615, UBUNTU-CVE-2026-53615

## What is CVE-2026-53615?

CVE-2026-53615 is a high-severity vulnerability in util-linux, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

util-linux is a random collection of Linux utilities. Before util-linux 2.41.4, `parse_dos_extended()` in `libblkid/src/partitions/dos.c` computes an extended-partition start sector with 32-bit addition and does not apply the extended-area bounds checks to the first two EBR entries. A local attacker who causes a crafted DOS extended-partition disk image or removable medium to be probed can wrap `cur_start + start` to sector zero and cause libblkid to report a false partition overlapping the MBR. This directly compromises the integrity of the reported partition metadata; disk modification or availability loss requires a separate downstream consumer to act on that metadata. This issue is fixed in 2.41.4.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-53615?


## How do I fix CVE-2026-53615?

Upgrade to a fixed version.

## Is CVE-2026-53615 being exploited?

There is no known exploitation of CVE-2026-53615 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53615 and fix it if it is affected.

What it is: CVE-2026-53615 is a high-severity vulnerability in util-linux, published on 14 Oct 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53615 in the wild and no public exploit code.

Affected product: util-linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53615/ (Markdown: https://insights.sbomify.com/CVE-2026-53615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53615
- OSV: https://osv.dev/vulnerability/CVE-2026-53615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53615/
Summaries are generated and may contain mistakes; the official description above is the record.
