# CVE-2026-53638: Sylius: Channel-based payment method restriction bypass on shop account orders API endpoint

> Authenticated users can bypass channel restrictions to assign unauthorized payment methods to their orders via the shop account API.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-6955-hrm5-c4qp

## What is CVE-2026-53638?

CVE-2026-53638 is a medium-severity missing authorization vulnerability in Sylius, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sylius is an Open Source eCommerce Framework on Symfony. Starting in version 2.0.0 and prior to version 2.0.18, 2.1.15, and 2.2.6, an authorization bypass vulnerability exists in the shop account API. The `PATCH /api/v2/shop/account/orders/{tokenValue}/payments/{paymentId}` endpoint, used by an authenticated shop customer to change the payment method of an order that has been placed but not yet paid (state `STATE_NEW`), does not validate that the chosen payment method is enabled for the order's channel. The equivalent checkout endpoint (`PATCH /api/v2/shop/orders/{tokenValue}/payments/{paymentId}`) correctly rejects out-of-channel payment methods with `HTTP 422`; the account endpoint silently accepts them and returns `HTTP 200`. An authenticated customer can therefore assign any globally enabled payment method to their own placed order, including methods that the store operator has explicitly excluded from that channel. The issue is fixed in versions: 2.0.18, 2.1.15, 2.2.6 and above. As a workaround, decorate the `Sylius\Bundle\ApiBundle\Changer\PaymentMethodChangerInterface` service in the application.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-53638?

6 open source packages ship an affected version, including sylius/sylius.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.18 |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.18 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.15 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.15 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.6 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.6 |

## How do I fix CVE-2026-53638?

Upgrade sylius/sylius to a fixed version for your release line: 2.0.18, 2.1.15 or 2.2.6.

## Is CVE-2026-53638 being exploited?

There is no known exploitation of CVE-2026-53638 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53638 and fix it if it is affected.

What it is: CVE-2026-53638 is a medium-severity missing authorization vulnerability in Sylius, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53638 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected from 2.0.0; fixed in 2.0.18
- sylius/sylius (Packagist): affected from 2.0.0; fixed in 2.0.18
- sylius/sylius (Packagist): affected from 2.1.0; fixed in 2.1.15
- sylius/sylius (Packagist): affected from 2.1.0; fixed in 2.1.15
- sylius/sylius (Packagist): affected from 2.2.0; fixed in 2.2.6
- sylius/sylius (Packagist): affected from 2.2.0; fixed in 2.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53638/ (Markdown: https://insights.sbomify.com/CVE-2026-53638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53638
- OSV: https://osv.dev/vulnerability/CVE-2026-53638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53638/
Summaries are generated and may contain mistakes; the official description above is the record.
