# CVE-2026-53639: Sylius: IDOR on Shop Payment Request API endpoints

> Attackers with a payment request hash can read order details and modify redirect URLs due to missing ownership checks in Sylius API endpoints.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-mr9r-h354-966r

## What is CVE-2026-53639?

CVE-2026-53639 is a medium-severity missing authorization vulnerability in Sylius, published on 8 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sylius is an Open Source eCommerce Framework on Symfony. Starting in version 2.0.0 and prior to version 2.0.18, 2.1.15, and 2.2.6, the `GET /api/v2/shop/payment-requests/{hash}` and `PUT /api/v2/shop/payment-requests/{hash}` endpoints look up the payment request solely by the hash from the URL. No ownership check is performed against the authenticated customer or the underlying order. An attacker who obtains a payment request hash can read the payment request and, through the `payment` IRI in the response, recover the underlying order's `tokenValue` (which itself grants access to the full order, items, addresses, customer email, totals); and/or update the payment request payload (e.g. `target_path`, `after_path`). These fields are used by the front-end controller to redirect the user after the payment, so an attacker can flip them to an attacker-controlled URL and intercept the buyer. The hash is a UUID, so it has to be obtained out-of-band (logs, shared links, referrer headers, a co-located client), but once it is known no other credential is required, neither authentication nor knowledge of the order token. The creation endpoint `POST /api/v2/shop/orders/{tokenValue}/payment-requests` shares the same flaw: it resolves the target order solely from the `tokenValue` in the URL without verifying that the caller owns the order. The issue is fixed in versions 2.0.18, 2.1.15, and 2.2.6. As a workaround, add a query extension that filters the `GET` operation; decorate the `PUT` state provider, guard the `POST` creation endpoint with a command-bus middleware, and wire the services.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-53639?

6 open source packages ship an affected version, including sylius/sylius.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.18 |
| `sylius/sylius` | Packagist | From 2.0.0 | 2.0.18 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.15 |
| `sylius/sylius` | Packagist | From 2.1.0 | 2.1.15 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.6 |
| `sylius/sylius` | Packagist | From 2.2.0 | 2.2.6 |

## How do I fix CVE-2026-53639?

Upgrade sylius/sylius to a fixed version for your release line: 2.0.18, 2.1.15 or 2.2.6.

## Is CVE-2026-53639 being exploited?

There is no known exploitation of CVE-2026-53639 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53639 and fix it if it is affected.

What it is: CVE-2026-53639 is a medium-severity missing authorization vulnerability in Sylius, published on 8 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53639 in the wild and no public exploit code.

Affected packages and fixed versions:
- sylius/sylius (Packagist): affected from 2.0.0; fixed in 2.0.18
- sylius/sylius (Packagist): affected from 2.0.0; fixed in 2.0.18
- sylius/sylius (Packagist): affected from 2.1.0; fixed in 2.1.15
- sylius/sylius (Packagist): affected from 2.1.0; fixed in 2.1.15
- sylius/sylius (Packagist): affected from 2.2.0; fixed in 2.2.6
- sylius/sylius (Packagist): affected from 2.2.0; fixed in 2.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53639/ (Markdown: https://insights.sbomify.com/CVE-2026-53639/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53639
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53639
- OSV: https://osv.dev/vulnerability/CVE-2026-53639

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53639/
Summaries are generated and may contain mistakes; the official description above is the record.
