# CVE-2026-53653: Grav: Unauthenticated denial of service via unbounded image derivative dimensions

> Unauthenticated attackers can exhaust server resources by requesting image derivatives with oversized dimensions, causing denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-4x9g-vw65-vvf9

## What is CVE-2026-53653?

CVE-2026-53653 is a high-severity denial of service vulnerability in getgrav grav, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 1.7.53 and 2.0.0-rc.8, Grav allows an unauthenticated visitor to exhaust server memory and CPU by requesting image derivatives with oversized dimensions through URL query image actions such as forceResize in Grav::fallbackUrl, which passes request parameters to ImageMedium magic actions without a dimension or pixel ceiling. This issue is fixed in versions 1.7.53 and 2.0.0-rc.8.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-53653?

4 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.53 |
| `getgrav/grav` | Packagist | All versions | 1.7.53 |
| `getgrav/grav` | Packagist | From 2.0.0-beta.1 | 2.0.0-rc.8 |
| `getgrav/grav` | Packagist | From 2.0.0-beta.1 | 2.0.0-rc.8 |

## How do I fix CVE-2026-53653?

Upgrade getgrav/grav to a fixed version for your release line: 1.7.53 or 2.0.0-rc.8.

## Is CVE-2026-53653 being exploited?

There is no known exploitation of CVE-2026-53653 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53653 and fix it if it is affected.

What it is: CVE-2026-53653 is a high-severity denial of service vulnerability in getgrav grav, published on 10 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53653 in the wild and no public exploit code.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.53
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.53
- getgrav/grav (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-rc.8
- getgrav/grav (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-rc.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53653/ (Markdown: https://insights.sbomify.com/CVE-2026-53653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53653
- OSV: https://osv.dev/vulnerability/CVE-2026-53653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53653/
Summaries are generated and may contain mistakes; the official description above is the record.
