CVE-2026-53659 http4k: Unbounded gzip decompression in `ServerFilters.GZip` / `RequestFilters.GunZip` allowed memory-exhaustion DoS
An unauthenticated attacker can cause memory exhaustion and service denial by sending small gzip payloads that expand excessively in http4k applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53659?
CVE-2026-53659 is a high-severity denial of service vulnerability in http4k, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
http4k is a functional toolkit for Kotlin HTTP applications. Prior to 4.51.0.0, 5.42.0.0, and 6.49.0.0, ServerFilters.GZip, RequestFilters.GunZip, and the underlying Gzip request-body decompression functions impose no limit on decompressed size. An unauthenticated client can send a small gzip-encoded request body that expands to gigabytes, exhausting the JVM heap and denying service to other clients. The fix uses SizeLimitedInputStream to enforce a default 10 MiB limit, causes ServerFilters.GZip and RequestFilters.GunZip to return 413 Request Entity Too Large, and causes other decompression paths to throw SizeLimitExceededException. This issue is fixed in versions 4.51.0.0, 5.42.0.0, and 6.49.0.0.
Weakness: CWE-409
Which versions are affected by CVE-2026-53659?
6 open source packages ship an affected version, including org.http4k:http4k-core.
| Package | Affected | Fixed in |
|---|---|---|
org.http4k:http4k-core Maven | All versions to 4.48.2.0 | None |
org.http4k:http4k-core Maven | All versions to 4.48.2.0 | None |
org.http4k:http4k-core Maven | From 5.0.0.0 | 5.42.0.0 |
org.http4k:http4k-core Maven | From 5.0.0.0 | 5.42.0.0 |
org.http4k:http4k-core Maven | From 6.0.0.0 | 6.49.0.0 |
org.http4k:http4k-core Maven | From 6.0.0.0 | 6.49.0.0 |
How do I fix CVE-2026-53659?
Upgrade org.http4k:http4k-core to a fixed version for your release line: 5.42.0.0 or 6.49.0.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-53659 being exploited?
There is no known exploitation of CVE-2026-53659 in the wild and no public exploit code.
Sources
Also known as GHSA-g4w2-6h2r-3m3w.