# CVE-2026-53670: PREVAIL: Non-singleton typeset in add() skips offset update, allowing OOB access to pass eBPF verification

> A flaw in the PREVAIL eBPF verifier allows crafted programs to bypass bounds checks, leading to out-of-bounds memory access and potential code execution.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Sep 2026
- **Updated:** 2 Sep 2026
- **Also known as:** GHSA-2qc8-qh94-66rc

## What is CVE-2026-53670?

CVE-2026-53670 is a critical memory corruption vulnerability in vbpf prevail, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PREVAIL is a Polynomial-Runtime EBPF Verifier using an Abstract Interpretation Layer. Prior to version 0.2.4, in the Prevail eBPF verifier, EbpfTransformer::add() silently skips offset-variable updates when the destination register carries a non-singleton typeset (two or more simultaneously possible pointer types). Subsequent bounds checks use the stale offset and accept out-of-bounds memory accesses, so a crafted BPF program passes verification even though it would corrupt memory at runtime. This issue has been patched in version 0.2.4.

Weakness: CWE-682 (Incorrect Calculation)

## Which versions are affected by CVE-2026-53670?


## How do I fix CVE-2026-53670?

No fix has been published for CVE-2026-53670 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53670 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53670 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53670 and fix it if it is affected.

What it is: CVE-2026-53670 is a critical memory corruption vulnerability in vbpf prevail, published on 2 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53670 exists.

Affected product: vbpf prevail. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53670/ (Markdown: https://insights.sbomify.com/CVE-2026-53670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53670
- OSV: https://osv.dev/vulnerability/CVE-2026-53670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53670/
Summaries are generated and may contain mistakes; the official description above is the record.
