{"answers":{"affected":"2 open source packages ship an affected version, including buddypress/buddypress.","exploited":"There is no known exploitation of CVE-2026-53673 in the wild and no public exploit code.","fix":"Upgrade buddypress/buddypress to 14.5.0 or later.","what":"CVE-2026-53673 is a high-severity missing authorization vulnerability in BuddyPress, published on 9 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53673 and fix it if it is affected.\n\nWhat it is: CVE-2026-53673 is a high-severity missing authorization vulnerability in BuddyPress, published on 9 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-53673 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- buddypress/buddypress (Packagist): affected all versions; fixed in 14.5.0\n- buddypress/buddypress (Packagist): affected all versions; fixed in 14.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53673/ (Markdown: https://insights.sbomify.com/CVE-2026-53673/index.md)","id":"CVE-2026-53673","markdown":"https://insights.sbomify.com/CVE-2026-53673/index.md","name":"CVE-2026-53673","record":{"aliases":["GHSA-j3j5-5m8v-7gvc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"BuddyPress plugin","requires_auth":"low_privilege","summary":"Authenticated attackers can access, reply to, or delete arbitrary private messages by manipulating the user_id parameter in the REST API.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"}],"description":"BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers to access arbitrary private message threads by supplying a user_id parameter in the request. Attackers can pass another user's identifier to the get_item_permissions_check method, which validates the supplied user_id instead of the logged-in user and is reused by the update and delete handlers, to read, reply to, or delete any user's private messages.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"BuddyPress 14.4.0 Private Message IDOR via REST API user_id Parameter","id":"CVE-2026-53673","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"BuddyPress 14.4.0 REGEXP Injection via @Mention Username Resolution","id":"CVE-2026-53674"},"packages":[{"ecosystem":"Packagist","fixed":["14.5.0"],"introduced":["0"],"last_affected":[],"package":"buddypress/buddypress","purl":null,"source":"GHSA-j3j5-5m8v-7gvc"},{"ecosystem":"Packagist","fixed":["14.5.0"],"introduced":["0"],"last_affected":[],"package":"buddypress/buddypress","purl":"pkg:composer/buddypress/buddypress","source":"GHSA-j3j5-5m8v-7gvc"}],"prev":{"headline":"PREVAIL: Context-write no-op in do_mem_store allows unsafe eBPF programs to pass verification","id":"CVE-2026-53671"},"products":["BuddyPress"],"published":"2026-06-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["BuddyPress"]},"summary":"Authenticated attackers can access, reply to, or delete arbitrary private messages by manipulating the user_id parameter in the REST API.","url":"https://insights.sbomify.com/CVE-2026-53673/"}