CVE-2026-53713 Envoy Gateway: Authentication Bypass via Improper Input Validation in EnvoyExtensionPolicy Lua Allows Secret Disclosure
Attackers can bypass path validation to read sensitive files like Kubernetes tokens from the gateway controller pod, potentially escalating privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53713?
CVE-2026-53713 is a critical path traversal vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, to_absolute_normalized_path in internal/gatewayapi/luavalidator/security.lua does not collapse redundant separators before is_critical_path evaluates Lua submitted through EnvoyExtensionPolicy during default Strict validation. Linux resolves a double-slash absolute path as the corresponding single-slash path, but the validator does not match the redundant-separator form, allowing submitted Lua to read arbitrary files from the gateway controller pod. Exposed files can include Kubernetes service-account tokens, TLS certificates, and process environment data, and the disclosed credentials can provide access to sensitive Kubernetes API Server or Gateway xDS server information. This issue is fixed in versions 1.7.4 and 1.8.1.
Weakness: CWE-20
Which versions are affected by CVE-2026-53713?
6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/gateway Go | All versions | 1.7.4, 1.8.1 |
github.com/envoyproxy/gateway Go | All versions | 1.7.4 |
github.com/envoyproxy/gateway Go | All versions | 1.7.4 |
github.com/envoyproxy/gateway Go | From 1.8.0-rc.0 | 1.8.1 |
github.com/envoyproxy/gateway Go | From 1.8.0-rc.0 | 1.8.1 |
envoy-gateway Bitnami | All versions | 1.7.4, 1.8.1 |
How do I fix CVE-2026-53713?
Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-53713 being exploited?
There is no known exploitation of CVE-2026-53713 in the wild and no public exploit code.
Sources
Also known as BIT-envoy-gateway-2026-53713, CLEANSTART-2026-JV13465, CLEANSTART-2026-UK63085, GHSA-wcrf-9vrr-854f, GO-2026-6011, MINI-3659-ph42-gv55 and 7 more.