{"answers":{"affected":"6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.","exploited":"There is no known exploitation of CVE-2026-53713 in the wild and no public exploit code.","fix":"Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.","what":"CVE-2026-53713 is a critical path traversal vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53713 and fix it if it is affected.\n\nWhat it is: CVE-2026-53713 is a critical path traversal vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-53713 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4, 1.8.1\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4\n- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1\n- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1\n- envoy-gateway (Bitnami): affected all versions; fixed in 1.7.4, 1.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53713/ (Markdown: https://insights.sbomify.com/CVE-2026-53713/index.md)","id":"CVE-2026-53713","markdown":"https://insights.sbomify.com/CVE-2026-53713/index.md","name":"CVE-2026-53713","record":{"aliases":["BIT-envoy-gateway-2026-53713","CLEANSTART-2026-JV13465","CLEANSTART-2026-UK63085","GHSA-wcrf-9vrr-854f","GO-2026-6011","MINI-3659-ph42-gv55","MINI-38vg-jm7c-6v67","MINI-3967-6x98-6rg5","MINI-52rq-6ghv-r4v4","MINI-54qg-487c-583r","MINI-62h7-c88h-x8fw","MINI-9p9f-ph8m-5999","MINI-pgr6-7844-4v45"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Envoy Gateway","requires_auth":"low_privilege","summary":"Attackers can bypass path validation to read sensitive files like Kubernetes tokens from the gateway controller pod, potentially escalating privileges.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, to_absolute_normalized_path in internal/gatewayapi/luavalidator/security.lua does not collapse redundant separators before is_critical_path evaluates Lua submitted through EnvoyExtensionPolicy during default Strict validation. Linux resolves a double-slash absolute path as the corresponding single-slash path, but the validator does not match the redundant-separator form, allowing submitted Lua to read arbitrary files from the gateway controller pod. Exposed files can include Kubernetes service-account tokens, TLS certificates, and process environment data, and the disclosed credentials can provide access to sensitive Kubernetes API Server or Gateway xDS server information. This issue is fixed in versions 1.7.4 and 1.8.1.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Envoy Gateway: Authentication Bypass via Improper Input Validation in EnvoyExtensionPolicy Lua Allows Secret Disclosure","id":"CVE-2026-53713","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":6,"n_references":9,"next":{"headline":"Envoy Gateway: xDS Control Plane Information Disclosure when Envoy Gateway operates in GatewayNamespaceMode","id":"CVE-2026-53714"},"packages":[{"ecosystem":"Bitnami","fixed":["1.7.4","1.8.1"],"introduced":["0","1.8.0"],"last_affected":[],"package":"envoy-gateway","purl":"pkg:bitnami/envoy-gateway","source":"BIT-envoy-gateway-2026-53713"},{"ecosystem":"Go","fixed":["1.7.4","1.8.1"],"introduced":["0","1.8.0-rc.0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":"pkg:golang/github.com/envoyproxy/gateway","source":"GO-2026-6011"},{"ecosystem":"Go","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":null,"source":"GHSA-wcrf-9vrr-854f"},{"ecosystem":"Go","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":"pkg:golang/github.com/envoyproxy/gateway","source":"GHSA-wcrf-9vrr-854f"},{"ecosystem":"Go","fixed":["1.8.1"],"introduced":["1.8.0-rc.0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":null,"source":"GHSA-wcrf-9vrr-854f"},{"ecosystem":"Go","fixed":["1.8.1"],"introduced":["1.8.0-rc.0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":"pkg:golang/github.com/envoyproxy/gateway","source":"GHSA-wcrf-9vrr-854f"}],"prev":{"headline":"SCRAM: Silent channel-binding authentication downgrade via unsupported certificate algorithms","id":"CVE-2026-53712"},"products":["gateway"],"published":"2026-09-14","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["envoyproxy"]},"summary":"Attackers can bypass path validation to read sensitive files like Kubernetes tokens from the gateway controller pod, potentially escalating privileges.","url":"https://insights.sbomify.com/CVE-2026-53713/"}