# CVE-2026-53713: Envoy Gateway: Authentication Bypass via Improper Input Validation in EnvoyExtensionPolicy Lua Allows Secret Disclosure

> Attackers can bypass path validation to read sensitive files like Kubernetes tokens from the gateway controller pod, potentially escalating privileges.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-envoy-gateway-2026-53713, CLEANSTART-2026-JV13465, CLEANSTART-2026-UK63085, GHSA-wcrf-9vrr-854f, GO-2026-6011, MINI-3659-ph42-gv55, MINI-38vg-jm7c-6v67, MINI-3967-6x98-6rg5, MINI-52rq-6ghv-r4v4, MINI-54qg-487c-583r, MINI-62h7-c88h-x8fw, MINI-9p9f-ph8m-5999, MINI-pgr6-7844-4v45

## What is CVE-2026-53713?

CVE-2026-53713 is a critical path traversal vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, to_absolute_normalized_path in internal/gatewayapi/luavalidator/security.lua does not collapse redundant separators before is_critical_path evaluates Lua submitted through EnvoyExtensionPolicy during default Strict validation. Linux resolves a double-slash absolute path as the corresponding single-slash path, but the validator does not match the redundant-separator form, allowing submitted Lua to read arbitrary files from the gateway controller pod. Exposed files can include Kubernetes service-account tokens, TLS certificates, and process environment data, and the disclosed credentials can provide access to sensitive Kubernetes API Server or Gateway xDS server information. This issue is fixed in versions 1.7.4 and 1.8.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-53713?

6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4, 1.8.1 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4 |
| `github.com/envoyproxy/gateway` | Go | From 1.8.0-rc.0 | 1.8.1 |
| `github.com/envoyproxy/gateway` | Go | From 1.8.0-rc.0 | 1.8.1 |
| `envoy-gateway` | Bitnami | All versions | 1.7.4, 1.8.1 |

## How do I fix CVE-2026-53713?

Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.

## Is CVE-2026-53713 being exploited?

There is no known exploitation of CVE-2026-53713 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53713 and fix it if it is affected.

What it is: CVE-2026-53713 is a critical path traversal vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53713 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4, 1.8.1
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4
- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1
- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1
- envoy-gateway (Bitnami): affected all versions; fixed in 1.7.4, 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53713/ (Markdown: https://insights.sbomify.com/CVE-2026-53713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53713
- OSV: https://osv.dev/vulnerability/CVE-2026-53713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53713/
Summaries are generated and may contain mistakes; the official description above is the record.
