CVE-2026-53714 Envoy Gateway: xDS Control Plane Information Disclosure when Envoy Gateway operates in GatewayNamespaceMode

High 7.4 Published Updated

Attackers with network access can retrieve sensitive TLS keys and routing configs from Envoy Gateway when GatewayNamespaceMode is enabled due to missing authentication on specific RPCs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-53714?

CVE-2026-53714 is a high-severity missing authorization vulnerability in envoyproxy gateway, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, the xDS gRPC server in GatewayNamespaceMode, configured through provider.kubernetes.deploy.type=GatewayNamespace, installs a JWT StreamInterceptor but no UnaryInterceptor, leaving every unary Fetch RPC unauthenticated. The streaming interceptor also authenticates only discoveryv3.DeltaDiscoveryRequest messages; a discoveryv3.DiscoveryRequest used by the State-of-the-World protocol fails the type assertion and returns success without JWT validation. Any pod that can reach port 18000 can use the unauthenticated unary or State-of-the-World paths to retrieve TLS private keys through StreamSecrets, all xDS resources through StreamAggregatedResources, backend endpoints through StreamClusters or StreamEndpoints, and routing configuration through StreamRoutes or StreamListeners. This issue is fixed in versions 1.7.4 and 1.8.1.

Weakness: CWE-306

Which versions are affected by CVE-2026-53714?

6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.

PackageAffectedFixed in
github.com/envoyproxy/gateway GoAll versions1.7.4, 1.8.1
github.com/envoyproxy/gateway GoAll versions1.7.4
github.com/envoyproxy/gateway GoAll versions1.7.4
github.com/envoyproxy/gateway GoFrom 1.8.0-rc.01.8.1
github.com/envoyproxy/gateway GoFrom 1.8.0-rc.01.8.1
envoy-gateway BitnamiAll versions1.7.4, 1.8.1

How do I fix CVE-2026-53714?

Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-53714 being exploited?

There is no known exploitation of CVE-2026-53714 in the wild and no public exploit code.

Sources

Also known as BIT-envoy-gateway-2026-53714, CLEANSTART-2026-BF33311, CLEANSTART-2026-VG58591, GHSA-22xc-xg2r-9j7v, GO-2026-6003, MINI-fmc4-9j2r-fh6c and 4 more.

Is CVE-2026-53714 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free