# CVE-2026-53714: Envoy Gateway: xDS Control Plane Information Disclosure when Envoy Gateway operates in GatewayNamespaceMode

> Attackers with network access can retrieve sensitive TLS keys and routing configs from Envoy Gateway when GatewayNamespaceMode is enabled due to missing authentication on specific RPCs.

- **Severity:** High 7.4 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** BIT-envoy-gateway-2026-53714, CLEANSTART-2026-BF33311, CLEANSTART-2026-VG58591, GHSA-22xc-xg2r-9j7v, GO-2026-6003, MINI-fmc4-9j2r-fh6c, MINI-mm7x-hfwm-3gqh, MINI-qm5h-5q72-vj3f, MINI-rh53-hr7q-75rj, ROOT-APP-GOBINARY-CVE-2026-53714

## What is CVE-2026-53714?

CVE-2026-53714 is a high-severity missing authorization vulnerability in envoyproxy gateway, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, the xDS gRPC server in GatewayNamespaceMode, configured through provider.kubernetes.deploy.type=GatewayNamespace, installs a JWT StreamInterceptor but no UnaryInterceptor, leaving every unary Fetch RPC unauthenticated. The streaming interceptor also authenticates only discoveryv3.DeltaDiscoveryRequest messages; a discoveryv3.DiscoveryRequest used by the State-of-the-World protocol fails the type assertion and returns success without JWT validation. Any pod that can reach port 18000 can use the unauthenticated unary or State-of-the-World paths to retrieve TLS private keys through StreamSecrets, all xDS resources through StreamAggregatedResources, backend endpoints through StreamClusters or StreamEndpoints, and routing configuration through StreamRoutes or StreamListeners. This issue is fixed in versions 1.7.4 and 1.8.1.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-53714?

6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4, 1.8.1 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4 |
| `github.com/envoyproxy/gateway` | Go | From 1.8.0-rc.0 | 1.8.1 |
| `github.com/envoyproxy/gateway` | Go | From 1.8.0-rc.0 | 1.8.1 |
| `envoy-gateway` | Bitnami | All versions | 1.7.4, 1.8.1 |

## How do I fix CVE-2026-53714?

Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.

## Is CVE-2026-53714 being exploited?

There is no known exploitation of CVE-2026-53714 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53714 and fix it if it is affected.

What it is: CVE-2026-53714 is a high-severity missing authorization vulnerability in envoyproxy gateway, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53714 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4, 1.8.1
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4
- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1
- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1
- envoy-gateway (Bitnami): affected all versions; fixed in 1.7.4, 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53714/ (Markdown: https://insights.sbomify.com/CVE-2026-53714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53714
- OSV: https://osv.dev/vulnerability/CVE-2026-53714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53714/
Summaries are generated and may contain mistakes; the official description above is the record.
