CVE-2026-53715 Envoy Gateway: Wasm cache ServeHTTP reads mappingPath2Cache without lock
An attacker can cause a denial of service in Envoy Gateway by triggering a race condition in the Wasm cache, crashing the controller process.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53715?
CVE-2026-53715 is a medium-severity vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, HTTPServer.ServeHTTP in internal/wasm/httpserver.go reads the plain mappingPath2Cache map without synchronization while HTTPServer.Get writes the same map during EnvoyExtensionPolicy translation. An attacker with pod-network access to unauthenticated port 18002 and tenant permission to churn policies with distinct Wasm URLs can flood GET requests until a per-request reader overlaps a writer. Go's concurrent map read and write detection invokes runtime.throw, which the net/http connection recovery cannot catch, terminating the controller process and causing a timing-dependent, cross-tenant control-plane denial of service until Kubernetes restarts the pod. This issue is fixed in versions 1.7.4 and 1.8.1.
Weakness: CWE-362
Which versions are affected by CVE-2026-53715?
6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/gateway Go | All versions | 1.7.4, 1.8.1 |
github.com/envoyproxy/gateway Go | All versions | 1.7.4 |
github.com/envoyproxy/gateway Go | All versions | 1.7.4 |
github.com/envoyproxy/gateway Go | From 1.8.0-rc.0 | 1.8.1 |
github.com/envoyproxy/gateway Go | From 1.8.0-rc.0 | 1.8.1 |
envoy-gateway Bitnami | All versions | 1.7.4, 1.8.1 |
How do I fix CVE-2026-53715?
Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.
Is CVE-2026-53715 being exploited?
There is no known exploitation of CVE-2026-53715 in the wild and no public exploit code.
Sources
Also known as BIT-envoy-gateway-2026-53715, CLEANSTART-2026-KY24374, CLEANSTART-2026-ZY58428, GHSA-8fv2-88gg-hm7q, GO-2026-6005, MINI-3mxw-vpw8-2p4g and 3 more.