# CVE-2026-53716: Envoy Gateway: Wasm HTTP fetch decompresses gzip without output-size limit

> Attackers can cause persistent control-plane outages in Envoy Gateway by supplying malicious compressed Wasm payloads that trigger unbounded memory allocation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-envoy-gateway-2026-53716, CLEANSTART-2026-FY77467, CLEANSTART-2026-JF19024, GHSA-cxpq-8v7q-cg56, GO-2026-6006, MINI-7hhq-5rpw-g7fv, MINI-92cx-gpvp-68xc, MINI-gpx5-wvhx-6xrx, MINI-w9fp-2q8f-4398

## What is CVE-2026-53716?

CVE-2026-53716 is a medium-severity denial of service vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, getFileFromGZ in internal/wasm/httpfetcher.go calls io.ReadAll on a gzip.Reader without limiting decompressed output when a tenant-controlled EnvoyExtensionPolicy.spec.wasm[].code.http.url points to a reachable compressed Wasm payload. The 256 MiB compressed-input cap does not constrain the expanded size, no operator Wasm URL allowlist exists, and the optional sha256 check occurs only after decompression, so a comparatively small gzip stream can force a multi-gigabyte allocation in the shared controller. The resulting out-of-memory termination restarts the controller, re-reconciles the persistent custom resource, and can create a persistent cross-tenant control-plane outage. This issue is fixed in versions 1.7.4 and 1.8.1.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-53716?

6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4, 1.8.1 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4 |
| `github.com/envoyproxy/gateway` | Go | From 1.8.0-rc.0 | 1.8.1 |
| `github.com/envoyproxy/gateway` | Go | From 1.8.0-rc.0 | 1.8.1 |
| `envoy-gateway` | Bitnami | All versions | 1.7.4, 1.8.1 |

## How do I fix CVE-2026-53716?

Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.

## Is CVE-2026-53716 being exploited?

There is no known exploitation of CVE-2026-53716 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53716 and fix it if it is affected.

What it is: CVE-2026-53716 is a medium-severity denial of service vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53716 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4, 1.8.1
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4
- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1
- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1
- envoy-gateway (Bitnami): affected all versions; fixed in 1.7.4, 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53716/ (Markdown: https://insights.sbomify.com/CVE-2026-53716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53716
- OSV: https://osv.dev/vulnerability/CVE-2026-53716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53716/
Summaries are generated and may contain mistakes; the official description above is the record.
