# CVE-2026-53717: Envoy Gateway: OCI layer extraction allocates make([]byte, h.Size) from untrusted tar header

> Attackers can crash the Envoy Gateway control plane by providing malicious OCI images with large tar headers, causing memory exhaustion.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** BIT-envoy-gateway-2026-53717, CLEANSTART-2026-CD63596, CLEANSTART-2026-ZU56180, GHSA-h7pq-86h8-rp5x, GO-2026-6008, MINI-7935-c5gc-hqvc, MINI-8pxq-429f-x56p, MINI-mr5p-fj33-chf9, MINI-r242-f282-vjw9

## What is CVE-2026-53717?

CVE-2026-53717 is a medium-severity denial of service vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, internal/wasm/imagefetcher.go follows tenant-controlled EnvoyExtensionPolicy spec.wasm[].code.image.url values to Docker or OCI Wasm layers, and extractWasmPluginBinary uses the untrusted tar-header h.Size value to allocate memory before validating the entry name or declared size. A small PAX or GNU tar header can therefore claim a multi-terabyte entry even though the surrounding LimitReader restricts only the bytes read from the stream, and no registry allowlist prevents a permitted tenant from selecting an attacker-controlled registry that the controller can reach. The allocation is attempted for every tar entry and can cause an unrecoverable Go runtime out-of-memory failure; because the custom resource persists, reconciliation repeatedly crash-loops the shared controller and causes a single-request, non-volumetric, cluster-wide control-plane denial of service. This issue is fixed in versions 1.7.4 and 1.8.1.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-53717?

6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4, 1.8.1 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.7.4 |
| `github.com/envoyproxy/gateway` | Go | From 1.8.0-rc.0 | 1.8.1 |
| `github.com/envoyproxy/gateway` | Go | From 1.8.0-rc.0 | 1.8.1 |
| `envoy-gateway` | Bitnami | All versions | 1.7.4, 1.8.1 |

## How do I fix CVE-2026-53717?

Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.

## Is CVE-2026-53717 being exploited?

There is no known exploitation of CVE-2026-53717 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53717 and fix it if it is affected.

What it is: CVE-2026-53717 is a medium-severity denial of service vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53717 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4, 1.8.1
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.7.4
- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1
- github.com/envoyproxy/gateway (Go): affected from 1.8.0-rc.0; fixed in 1.8.1
- envoy-gateway (Bitnami): affected all versions; fixed in 1.7.4, 1.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53717/ (Markdown: https://insights.sbomify.com/CVE-2026-53717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53717
- OSV: https://osv.dev/vulnerability/CVE-2026-53717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53717/
Summaries are generated and may contain mistakes; the official description above is the record.
