CVE-2026-53719 Envoy Gateway: Nil-dereference when SecurityPolicy targets TCPRoute without spec.authorization
A nil pointer dereference in Envoy Gateway causes a panic and stalls control plane updates when a SecurityPolicy targets a TCPRoute without authorization, requiring an upgrade.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53719?
CVE-2026-53719 is a medium-severity vulnerability in envoyproxy gateway, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, translateSecurityPolicyForRoute in internal/gatewayapi/securitypolicy.go dereferences a nil authorization value when a namespace-scoped tenant creates a SecurityPolicy targeting a TCPRoute and omits spec.authorization. The persistent object triggers the panic on every reconcile; recovery in message/watchutil.go keeps the process alive but unwinds the runner/runner.go handle callback, stalling controller-wide xDS and infrastructure intermediate-representation publishing until an administrator deletes the object. The data plane continues to serve the last known good configuration while publication is stalled. This issue is fixed in versions 1.7.4 and 1.8.1.
Weakness: CWE-476
Which versions are affected by CVE-2026-53719?
6 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway.
| Package | Affected | Fixed in |
|---|---|---|
github.com/envoyproxy/gateway Go | All versions | 1.7.4, 1.8.1 |
github.com/envoyproxy/gateway Go | All versions | 1.7.4 |
github.com/envoyproxy/gateway Go | All versions | 1.7.4 |
github.com/envoyproxy/gateway Go | From 1.8.0-rc.0 | 1.8.1 |
github.com/envoyproxy/gateway Go | From 1.8.0-rc.0 | 1.8.1 |
envoy-gateway Bitnami | All versions | 1.7.4, 1.8.1 |
How do I fix CVE-2026-53719?
Upgrade github.com/envoyproxy/gateway to a fixed version for your release line: 1.7.4 or 1.8.1.
Is CVE-2026-53719 being exploited?
There is no known exploitation of CVE-2026-53719 in the wild and no public exploit code.
Sources
Also known as BIT-envoy-gateway-2026-53719, CLEANSTART-2026-IG75377, CLEANSTART-2026-XZ22302, GHSA-m2v6-2jmh-4c68, GO-2026-6009, MINI-6c3h-cc5c-3j9f and 3 more.