{"answers":{"affected":"3 open source packages ship an affected version, including pymonocypher.","exploited":"There is no known exploitation of CVE-2026-53720 in the wild and no public exploit code.","fix":"Upgrade pymonocypher to 4.0.2.8 or later.","what":"CVE-2026-53720 is a medium-severity memory corruption vulnerability in jetperch pymonocypher, published on 3 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53720 and fix it if it is affected.\n\nWhat it is: CVE-2026-53720 is a medium-severity memory corruption vulnerability in jetperch pymonocypher, published on 3 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-53720 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pymonocypher (PyPI): affected all versions; fixed in 4.0.2.8\n- pymonocypher (PyPI): affected all versions; fixed in 4.0.2.8\n- pymonocypher (PyPI): affected all versions; fixed in 4.0.2.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53720/ (Markdown: https://insights.sbomify.com/CVE-2026-53720/index.md)","id":"CVE-2026-53720","markdown":"https://insights.sbomify.com/CVE-2026-53720/index.md","name":"CVE-2026-53720","record":{"aliases":["GHSA-8f95-v3jq-cj86","PYSEC-2026-3000"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python crypto library","requires_auth":"none","summary":"Heap buffer overflow in pymonocypher's argon2i_32 allows attackers to corrupt memory and potentially execute code if a small buffer is provided.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-1284","name":"Improper Validation of Specified Quantity in Input"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"pymonocypher uses cython to wrap the Monocypher C library. Prior to version 4.0.2.8, the argon2i_32 implementation does not check the nb_blocks size. If the caller does not provide a sufficiently large buffer based on the API contract, then argon2i_32 will write past the end of the buffer and possibly corrupt the heap. This issue has been patched in version 4.0.2.8.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pymonocypher: Potential heap buffer overflow on nb_blocks in argon2i_32 when provided buffer is too small","id":"CVE-2026-53720","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Nuxt: Route-rule middleware bypass via case-sensitivity mismatch between vue-router and the routeRules matcher","id":"CVE-2026-53721"},"packages":[{"ecosystem":"PyPI","fixed":["4.0.2.8"],"introduced":["0"],"last_affected":[],"package":"pymonocypher","purl":null,"source":"GHSA-8f95-v3jq-cj86"},{"ecosystem":"PyPI","fixed":["4.0.2.8"],"introduced":["0"],"last_affected":[],"package":"pymonocypher","purl":"pkg:pypi/pymonocypher","source":"GHSA-8f95-v3jq-cj86"},{"ecosystem":"PyPI","fixed":["4.0.2.8"],"introduced":["0"],"last_affected":[],"package":"pymonocypher","purl":"pkg:pypi/pymonocypher","source":"PYSEC-2026-3000"}],"prev":{"headline":"Envoy Gateway: Nil-dereference when SecurityPolicy targets TCPRoute without spec.authorization","id":"CVE-2026-53719"},"products":["pymonocypher"],"published":"2026-09-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-03","vendors":["jetperch"]},"summary":"Heap buffer overflow in pymonocypher's argon2i_32 allows attackers to corrupt memory and potentially execute code if a small buffer is provided.","url":"https://insights.sbomify.com/CVE-2026-53720/"}