CVE-2026-53725 parse-server: Endpoints `/login` and `/verifyPassword` disclose MFA secrets and protected fields when `_User` get is denied

Medium 5.9 Published Updated

Attackers with valid credentials can retrieve MFA secrets and protected fields via login endpoints when user get permissions are denied, bypassing two-factor authentication.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-53725?

CVE-2026-53725 is a medium-severity vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. From version 9.8.0 to before version 9.9.1-alpha.5, apps that enable MFA and deny get on the _User class via Class-Level Permissions could expose sensitive user data through the /login and /verifyPassword endpoints. These endpoints re-fetch the user through the access-controlled query pipeline (CLP, protectedFields, auth-adapter sanitizers) before responding. When that re-fetch was denied by the _User get permission, the server fell back to the raw database row, exposing raw authData (including MFA TOTP secrets and recovery codes) and fields hidden by protectedFields (when protectedFieldsOwnerExempt is false). /verifyPassword is the most severe: with only a username and password (no session or MFA token), an attacker who knows a victim's password could retrieve their MFA secret and recovery codes, defeating the second factor. This issue has been patched in version 9.9.1-alpha.5.

Weakness: CWE-200

Which versions are affected by CVE-2026-53725?

3 open source packages ship an affected version, including parse-server and parse.

PackageAffectedFixed in
parse-server npmFrom 9.8.09.9.1-alpha.5
parse-server npmFrom 9.8.09.9.1-alpha.5
parse BitnamiFrom 9.8.09.9.1

How do I fix CVE-2026-53725?

Upgrade parse-server to 9.9.1-alpha.5 or later.

Is CVE-2026-53725 being exploited?

There is no known exploitation of CVE-2026-53725 in the wild and no public exploit code.

Sources

Also known as BIT-parse-2026-53725, GHSA-75v4-m273-5j49.

Is CVE-2026-53725 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free