CVE-2026-53726 Parse Server: Relation `$relatedTo` query bypasses `protectedFields` and owning-object ACL
Unauthenticated attackers can bypass protectedFields and ACLs to enumerate private relation memberships in Parse Server applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53726?
CVE-2026-53726 is a medium-severity missing authorization vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.80 and 9.9.1-alpha.6, a relation query using the $relatedTo operator could read the membership of a Relation field even when that field was hidden from the requesting client by protectedFields, and even when the object owning the relation was not readable by the client under its ACL or class-level permissions. The request requires only the public API credentials that Parse clients normally carry — no user session, master key, or Cloud Code is needed. As a result, an unauthenticated client who knows or obtains the owning object's objectId could enumerate the objects linked through a protected relation, or combine the operator with an objectId constraint to use it as a membership oracle — confirming whether a specific object is linked to a private parent. This affects applications that rely on protectedFields or object ACLs to keep Relation membership confidential, such as private group memberships, block lists, or account-to-resource associations. This issue has been patched in versions 8.6.80 and 9.9.1-alpha.6.
Weakness: CWE-639
Which versions are affected by CVE-2026-53726?
5 open source packages ship an affected version, including parse-server and parse.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.80 |
parse-server npm | All versions | 8.6.80 |
parse-server npm | From 9.0.0 | 9.9.1-alpha.6 |
parse-server npm | From 9.0.0 | 9.9.1-alpha.6 |
parse Bitnami | All versions | 8.6.80, 9.9.1 |
How do I fix CVE-2026-53726?
Upgrade parse-server to a fixed version for your release line: 8.6.80 or 9.9.1-alpha.6.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-53726 being exploited?
There is no known exploitation of CVE-2026-53726 in the wild and no public exploit code.
Sources
Also known as BIT-parse-2026-53726, GHSA-wmwx-jr2p-4j4r.