# CVE-2026-53726: Parse Server: Relation `$relatedTo` query bypasses `protectedFields` and owning-object ACL

> Unauthenticated attackers can bypass protectedFields and ACLs to enumerate private relation memberships in Parse Server applications.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** BIT-parse-2026-53726, GHSA-wmwx-jr2p-4j4r

## What is CVE-2026-53726?

CVE-2026-53726 is a medium-severity missing authorization vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.80 and 9.9.1-alpha.6, a relation query using the $relatedTo operator could read the membership of a Relation field even when that field was hidden from the requesting client by protectedFields, and even when the object owning the relation was not readable by the client under its ACL or class-level permissions. The request requires only the public API credentials that Parse clients normally carry — no user session, master key, or Cloud Code is needed. As a result, an unauthenticated client who knows or obtains the owning object's objectId could enumerate the objects linked through a protected relation, or combine the operator with an objectId constraint to use it as a membership oracle — confirming whether a specific object is linked to a private parent. This affects applications that rely on protectedFields or object ACLs to keep Relation membership confidential, such as private group memberships, block lists, or account-to-resource associations. This issue has been patched in versions 8.6.80 and 9.9.1-alpha.6.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-53726?

5 open source packages ship an affected version, including parse-server and parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.80 |
| `parse-server` | npm | All versions | 8.6.80 |
| `parse-server` | npm | From 9.0.0 | 9.9.1-alpha.6 |
| `parse-server` | npm | From 9.0.0 | 9.9.1-alpha.6 |
| `parse` | Bitnami | All versions | 8.6.80, 9.9.1 |

## How do I fix CVE-2026-53726?

Upgrade parse-server to a fixed version for your release line: 8.6.80 or 9.9.1-alpha.6.

## Is CVE-2026-53726 being exploited?

There is no known exploitation of CVE-2026-53726 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53726 and fix it if it is affected.

What it is: CVE-2026-53726 is a medium-severity missing authorization vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53726 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.80
- parse-server (npm): affected all versions; fixed in 8.6.80
- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.6
- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.6
- parse (Bitnami): affected all versions; fixed in 8.6.80, 9.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53726/ (Markdown: https://insights.sbomify.com/CVE-2026-53726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53726
- OSV: https://osv.dev/vulnerability/CVE-2026-53726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53726/
Summaries are generated and may contain mistakes; the official description above is the record.
