{"answers":{"affected":"2 open source packages ship an affected version, including css_parser. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53727 exists.","fix":"Upgrade css_parser to 3.0.0 or later.","what":"CVE-2026-53727 is a high-severity server-side request forgery vulnerability in premailer css_parser, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53727 and fix it if it is affected.\n\nWhat it is: CVE-2026-53727 is a high-severity server-side request forgery vulnerability in premailer css_parser, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53727 exists.\n\nAffected packages and fixed versions:\n- css_parser (RubyGems): affected all versions; fixed in 3.0.0\n- css_parser (RubyGems): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53727/ (Markdown: https://insights.sbomify.com/CVE-2026-53727/index.md)","id":"CVE-2026-53727","markdown":"https://insights.sbomify.com/CVE-2026-53727/index.md","name":"CVE-2026-53727","record":{"aliases":["DEBIAN-CVE-2026-53727","GHSA-9pmc-p236-855h","UBUNTU-CVE-2026-53727"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby CSS parser","requires_auth":"none","summary":"Attackers can exploit Server-Side Request Forgery and local file disclosure in the css_parser library by providing malicious CSS with a base URI.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"css_parser","vendor":"premailer"}],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"css_parser is a Ruby CSS parser. From 2.2.0 until 3.0.0, CssParser::Parser#read_remote_file in lib/css_parser/parser.rb, and therefore load_uri! and the @import-following branch of add_block!, issued HTTP and HTTPS requests against any host, port, and URI without a scheme allowlist, host or IP filtering, or protection against link-local, loopback, or RFC-1918 addresses. Location: redirects were followed recursively back into the same function, which also serviced file:// URIs, so a single attacker-controlled HTTP redirect could upgrade the bug from SSRF to arbitrary local file disclosure. Any consumer of css_parser that hands it attacker-influenced CSS together with a base_uri: option is exposed. This issue is fixed in version 3.0.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"css_parser: SSRF and Local File Disclosure in `CssParser::Parser#read_remote_file`","id":"CVE-2026-53727","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Medplum - Improper Validation of Redirect URI in External Auth Callback allows Authorization Code Leakage","id":"CVE-2026-53728"},"packages":[{"ecosystem":"RubyGems","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"css_parser","purl":null,"source":"GHSA-9pmc-p236-855h"},{"ecosystem":"RubyGems","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"css_parser","purl":"pkg:gem/css_parser","source":"GHSA-9pmc-p236-855h"}],"prev":{"headline":"Parse Server: Relation `$relatedTo` query bypasses `protectedFields` and owning-object ACL","id":"CVE-2026-53726"},"products":["css_parser"],"published":"2026-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-20","vendors":["premailer"]},"summary":"Attackers can exploit Server-Side Request Forgery and local file disclosure in the css_parser library by providing malicious CSS with a base URI.","url":"https://insights.sbomify.com/CVE-2026-53727/"}