{"answers":{"affected":"2 open source packages ship an affected version, including @medplum/core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53728 exists.","fix":"Upgrade @medplum/core to 5.1.6 or later.","what":"CVE-2026-53728 is a high-severity vulnerability in medplum, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-53728 and fix it if it is affected.\n\nWhat it is: CVE-2026-53728 is a high-severity vulnerability in medplum, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53728 exists.\n\nAffected packages and fixed versions:\n- @medplum/core (npm): affected all versions; fixed in 5.1.6\n- @medplum/core (npm): affected all versions; fixed in 5.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53728/ (Markdown: https://insights.sbomify.com/CVE-2026-53728/index.md)","id":"CVE-2026-53728","markdown":"https://insights.sbomify.com/CVE-2026-53728/index.md","name":"CVE-2026-53728","record":{"aliases":["CLSA-2026-1792160935","CLSA-2026-1792160946","CLSA-2026-1792161495","CLSA-2026-1792161611","CLSA-2026-1792161726","CLSA-2026-1792161773","CLSA-2026-1792161869","CLSA-2026-1792161915","CLSA-2026-1792161966","CLSA-2026-1792162002","CLSA-2026-1792162031","CLSA-2026-1792162058","CLSA-2026-1792162080","CLSA-2026-1792162104","CLSA-2026-1792162106","CLSA-2026-1792162131","CLSA-2026-1792162152","CLSA-2026-1792162169","GHSA-m44r-7c5h-m6mj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Medplum healthcare platform","requires_auth":"none","summary":"Attackers can leak authorization codes by exploiting improper redirect URI validation in the external authentication callback, potentially leading to account takeover.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"},{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"}],"description":"Medplum is a developer platform that enables development of healthcare apps. Prior to version 5.1.6, the external identity provider callback at GET /auth/external accepts attacker-controlled redirect URIs that only need to start with a registered client redirect URI, rather than matching exactly. After a successful external IdP login, the server appends Medplum login and code values to that attacker-supplied URL and issues a redirect. Because the external login request state is serialized as raw JSON and later trusted by the callback, an attacker who can tamper with state.redirectUri can cause Medplum to redirect authorization artifacts to an attacker-controlled endpoint. When the registered redirect URI is a bare origin or another prefix that can be extended into a different hostname, this becomes a cross-origin authorization code leak. This issue has been patched in version 5.1.6.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Medplum - Improper Validation of Redirect URI in External Auth Callback allows Authorization Code Leakage","id":"CVE-2026-53728","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"open_redirect","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"DataEase ExportCenter IDOR allows cross-user export task access","id":"CVE-2026-53729"},"packages":[{"ecosystem":"npm","fixed":["5.1.6"],"introduced":["0"],"last_affected":[],"package":"@medplum/core","purl":null,"source":"GHSA-m44r-7c5h-m6mj"},{"ecosystem":"npm","fixed":["5.1.6"],"introduced":["0"],"last_affected":[],"package":"@medplum/core","purl":"pkg:npm/%40medplum/core","source":"GHSA-m44r-7c5h-m6mj"}],"prev":{"headline":"css_parser: SSRF and Local File Disclosure in `CssParser::Parser#read_remote_file`","id":"CVE-2026-53727"},"products":["medplum"],"published":"2026-09-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-09","vendors":["medplum"]},"summary":"Attackers can leak authorization codes by exploiting improper redirect URI validation in the external authentication callback, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2026-53728/"}