# CVE-2026-53728: Medplum - Improper Validation of Redirect URI in External Auth Callback allows Authorization Code Leakage

> Attackers can leak authorization codes by exploiting improper redirect URI validation in the external authentication callback, potentially leading to account takeover.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** CLSA-2026-1792160935, CLSA-2026-1792160946, CLSA-2026-1792161495, CLSA-2026-1792161611, CLSA-2026-1792161726, CLSA-2026-1792161773, CLSA-2026-1792161869, CLSA-2026-1792161915, CLSA-2026-1792161966, CLSA-2026-1792162002, CLSA-2026-1792162031, CLSA-2026-1792162058, CLSA-2026-1792162080, CLSA-2026-1792162104, CLSA-2026-1792162106, CLSA-2026-1792162131, CLSA-2026-1792162152, CLSA-2026-1792162169, GHSA-m44r-7c5h-m6mj

## What is CVE-2026-53728?

CVE-2026-53728 is a high-severity vulnerability in medplum, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Medplum is a developer platform that enables development of healthcare apps. Prior to version 5.1.6, the external identity provider callback at GET /auth/external accepts attacker-controlled redirect URIs that only need to start with a registered client redirect URI, rather than matching exactly. After a successful external IdP login, the server appends Medplum login and code values to that attacker-supplied URL and issues a redirect. Because the external login request state is serialized as raw JSON and later trusted by the callback, an attacker who can tamper with state.redirectUri can cause Medplum to redirect authorization artifacts to an attacker-controlled endpoint. When the registered redirect URI is a bare origin or another prefix that can be extended into a different hostname, this becomes a cross-origin authorization code leak. This issue has been patched in version 5.1.6.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-53728?

2 open source packages ship an affected version, including @medplum/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@medplum/core` | npm | All versions | 5.1.6 |
| `@medplum/core` | npm | All versions | 5.1.6 |

## How do I fix CVE-2026-53728?

Upgrade @medplum/core to 5.1.6 or later.

## Is CVE-2026-53728 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53728 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53728 and fix it if it is affected.

What it is: CVE-2026-53728 is a high-severity vulnerability in medplum, published on 3 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53728 exists.

Affected packages and fixed versions:
- @medplum/core (npm): affected all versions; fixed in 5.1.6
- @medplum/core (npm): affected all versions; fixed in 5.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53728/ (Markdown: https://insights.sbomify.com/CVE-2026-53728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53728
- OSV: https://osv.dev/vulnerability/CVE-2026-53728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53728/
Summaries are generated and may contain mistakes; the official description above is the record.
