# CVE-2026-53753: Crawl4AI: AST Sandbox Escape via gi_frame.f_back Chain - Pre-Auth RCE in Docker API

> Attackers can achieve remote code execution via sandbox escape in Crawl4AI's AST validator, requiring no authentication.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-qxjp-w3pj-48m7, PYSEC-2026-319

## What is CVE-2026-53753?

CVE-2026-53753 is a critical code injection vulnerability in unclecode crawl4ai, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Crawl4AI is an open-source LLM friendly web crawler & scraper. Prior to 0.8.7, the _safe_eval_expression() function in the computed fields feature uses an AST validator that only blocks attributes starting with underscore. Python generator and frame object attributes (gi_frame, f_back, f_builtins) do NOT start with underscore, enabling a complete sandbox escape to achieve arbitrary code execution. The attack requires no authentication (JWT disabled by default) and is triggered via POST /crawl with a crafted extraction schema. This vulnerability is fixed in 0.8.7.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2026-53753?

3 open source packages ship an affected version, including crawl4ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crawl4ai` | PyPI | All versions | 0.8.7 |
| `crawl4ai` | PyPI | All versions | 0.8.7 |
| `crawl4ai` | PyPI | All versions | 0.8.7 |

Products: Kidocode Crawl4ai.

## How do I fix CVE-2026-53753?

Upgrade crawl4ai to 0.8.7 or later.

## Is CVE-2026-53753 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53753 exists.

Public exploit code:

- CVE-2026-53753 — Crawl4AI <0.8.7 unauthenticated RCE (AST sandbox escape via gi_frame.f_back). Lab + PoC, verified e2e. (github_poc): https://github.com/BiiTts/CVE-2026-53753-Crawl4AI-RCE
- Crawl4AI <= 0.8.6 pre-auth RCE via AST sandbox escape (gi_frame.f_back.f_builtins chain) — CVSS 10.0 (github_poc): https://github.com/0xEnc0der/CVE-2026-53753
- Crawl4AI <= 0.8.6 - Remote Code Execution (nuclei): http/cves/2026/CVE-2026-53753.yaml

## Other vulnerabilities in unclecode crawl4ai

- [CVE-2026-57572](https://insights.sbomify.com/CVE-2026-57572/): Crawl4AI: Unauthenticated RCE via Chromium launch-argument injection in browser_config.extra_args (critical 10.0)
- [CVE-2026-26216](https://insights.sbomify.com/CVE-2026-26216/): Crawl4AI < 0.8.0 Docker API Unauthenticated Remote Code Execution via Hooks Parameter (critical 10.0)
- [CVE-2026-57571](https://insights.sbomify.com/CVE-2026-57571/): Crawl4AI arbitrary file write via download filename path traversal (critical 9.6)
- [CVE-2026-56265](https://insights.sbomify.com/CVE-2026-56265/): Crawl4AI - Authentication Bypass via Hardcoded JWT Signing Key (critical 9.3)
- [CVE-2026-56261](https://insights.sbomify.com/CVE-2026-56261/): Crawl4AI - Server-Side Request Forgery via Webhook URLs (critical 9.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53753 and fix it if it is affected.

What it is: CVE-2026-53753 is a critical code injection vulnerability in unclecode crawl4ai, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53753 exists.

Affected packages and fixed versions:
- crawl4ai (PyPI): affected all versions; fixed in 0.8.7
- crawl4ai (PyPI): affected all versions; fixed in 0.8.7
- crawl4ai (PyPI): affected all versions; fixed in 0.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53753/ (Markdown: https://insights.sbomify.com/CVE-2026-53753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53753
- OSV: https://osv.dev/vulnerability/CVE-2026-53753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53753/
Summaries are generated and may contain mistakes; the official description above is the record.
