# CVE-2026-53755: Crawl4AI: SSRF via proxy settings in the Docker server bypasses the crawl-URL SSRF check

> Unauthenticated attackers can bypass SSRF checks by specifying malicious proxy settings in Crawl4AI Docker API requests, accessing internal services and cloud metadata.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-6qhc-x826-342c, PYSEC-2026-588

## What is CVE-2026-53755?

CVE-2026-53755 is a high-severity server-side request forgery vulnerability in unclecode crawl4ai, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Crawl4AI is an open-source LLM friendly web crawler & scraper. Prior to 0.8.9, the Docker API server applied its SSRF destination check to the crawl target URL only, not to the proxy address. An unauthenticated request could supply a proxy pointing at an internal IP and route the browser through it, reaching internal services and cloud-metadata endpoints, while using a perfectly valid crawl URL. The Docker API is unauthenticated by default. /crawl, /crawl/stream, and /crawl/job accept a browser_config (and crawler_config). The following all feed Chromium's egress and were unchecked: browser_config.proxy_config.server, browser_config.proxy (deprecated field), crawler_config.proxy_config.server, and --proxy-server / --proxy-pac-url / --proxy-bypass-list / --host-resolver-rules flags in browser_config.extra_args. This vulnerability is fixed in 0.8.9.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-53755?

3 open source packages ship an affected version, including crawl4ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crawl4ai` | PyPI | All versions | 0.8.9 |
| `crawl4ai` | PyPI | All versions | 0.8.9 |
| `crawl4ai` | PyPI | All versions | 0.8.9 |

Products: Kidocode Crawl4ai.

## How do I fix CVE-2026-53755?

Upgrade crawl4ai to 0.8.9 or later.

## Is CVE-2026-53755 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53755 exists.

Public exploit code:

- crawl4ai < 0.8.9 - Server Side Request Forgery (nuclei): http/cves/2026/CVE-2026-53755.yaml

## Other vulnerabilities in unclecode crawl4ai

- [CVE-2026-57572](https://insights.sbomify.com/CVE-2026-57572/): Crawl4AI: Unauthenticated RCE via Chromium launch-argument injection in browser_config.extra_args (critical 10.0)
- [CVE-2026-26216](https://insights.sbomify.com/CVE-2026-26216/): Crawl4AI < 0.8.0 Docker API Unauthenticated Remote Code Execution via Hooks Parameter (critical 10.0)
- [CVE-2026-53753](https://insights.sbomify.com/CVE-2026-53753/): Crawl4AI: AST Sandbox Escape via gi_frame.f_back Chain - Pre-Auth RCE in Docker API (critical 9.8)
- [CVE-2026-57571](https://insights.sbomify.com/CVE-2026-57571/): Crawl4AI arbitrary file write via download filename path traversal (critical 9.6)
- [CVE-2026-56265](https://insights.sbomify.com/CVE-2026-56265/): Crawl4AI - Authentication Bypass via Hardcoded JWT Signing Key (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53755 and fix it if it is affected.

What it is: CVE-2026-53755 is a high-severity server-side request forgery vulnerability in unclecode crawl4ai, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53755 exists.

Affected packages and fixed versions:
- crawl4ai (PyPI): affected all versions; fixed in 0.8.9
- crawl4ai (PyPI): affected all versions; fixed in 0.8.9
- crawl4ai (PyPI): affected all versions; fixed in 0.8.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53755/ (Markdown: https://insights.sbomify.com/CVE-2026-53755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53755
- OSV: https://osv.dev/vulnerability/CVE-2026-53755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53755/
Summaries are generated and may contain mistakes; the official description above is the record.
