{"answers":{"affected":"2 open source packages ship an affected version, including avo.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53769 exists.","fix":"Upgrade avo to 3.32.0 or later.","what":"CVE-2026-53769 is a medium-severity missing authorization vulnerability in avo-hq avo, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53769 and fix it if it is affected.\n\nWhat it is: CVE-2026-53769 is a medium-severity missing authorization vulnerability in avo-hq avo, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53769 exists.\n\nAffected packages and fixed versions:\n- avo (RubyGems): affected from 2.28.0; fixed in 3.32.0\n- avo (RubyGems): affected from 2.28.0; fixed in 3.32.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53769/ (Markdown: https://insights.sbomify.com/CVE-2026-53769/index.md)","id":"CVE-2026-53769","markdown":"https://insights.sbomify.com/CVE-2026-53769/index.md","name":"CVE-2026-53769","record":{"aliases":["GHSA-pqpw-cvm4-8mv9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails admin framework","requires_auth":"low_privilege","summary":"Authenticated users can bypass upload policies to modify attachment content on records, affecting Avo admin panel deployments.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-862","name":"Missing Authorization"}],"description":"Avo is a framework to create admin panels for Ruby on Rails apps. From version 2.28.0 to before version 3.32.0, Avo's direct attachment upload endpoint lacks server-side upload authorization and bypasses the documented field-level upload policy methods such as upload_{FIELD_ID}?. An authenticated Avo user who can reach the Avo attachment upload endpoint can replace or add attachment content, including binary content, filename, and content-type metadata, on a resolved record even when both update? and upload_\u003cfield\u003e? policies deny the operation. This primarily affects multi-role Avo Pro/Advanced-style deployments where non-administrator or restricted operator users can reach Avo and per-record or per-field operations are expected to be enforced by policies. This issue has been patched in version 3.32.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Avo: Direct attachment upload endpoint lacks upload authorization and bypasses field-level upload policy","id":"CVE-2026-53769","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Perry \u003c 0.5.1166 JWT Expiration Bypass via verify_decode","id":"CVE-2026-53776"},"packages":[{"ecosystem":"RubyGems","fixed":["3.32.0"],"introduced":["2.28.0"],"last_affected":[],"package":"avo","purl":null,"source":"GHSA-pqpw-cvm4-8mv9"},{"ecosystem":"RubyGems","fixed":["3.32.0"],"introduced":["2.28.0"],"last_affected":[],"package":"avo","purl":"pkg:gem/avo","source":"GHSA-pqpw-cvm4-8mv9"}],"prev":{"headline":"chrome-devtools-mcp: validatePath() does not canonicalize symlinks before enforcing roots","id":"CVE-2026-53766"},"products":["avo"],"published":"2026-09-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-09","vendors":["avo-hq"]},"summary":"Authenticated users can bypass upload policies to modify attachment content on records, affecting Avo admin panel deployments.","url":"https://insights.sbomify.com/CVE-2026-53769/"}