# CVE-2026-53769: Avo: Direct attachment upload endpoint lacks upload authorization and bypasses field-level upload policy

> Authenticated users can bypass upload policies to modify attachment content on records, affecting Avo admin panel deployments.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-pqpw-cvm4-8mv9

## What is CVE-2026-53769?

CVE-2026-53769 is a medium-severity missing authorization vulnerability in avo-hq avo, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Avo is a framework to create admin panels for Ruby on Rails apps. From version 2.28.0 to before version 3.32.0, Avo's direct attachment upload endpoint lacks server-side upload authorization and bypasses the documented field-level upload policy methods such as upload_{FIELD_ID}?. An authenticated Avo user who can reach the Avo attachment upload endpoint can replace or add attachment content, including binary content, filename, and content-type metadata, on a resolved record even when both update? and upload_<field>? policies deny the operation. This primarily affects multi-role Avo Pro/Advanced-style deployments where non-administrator or restricted operator users can reach Avo and per-record or per-field operations are expected to be enforced by policies. This issue has been patched in version 3.32.0.

Weakness: CWE-863 (Incorrect Authorization), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-53769?

2 open source packages ship an affected version, including avo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `avo` | RubyGems | From 2.28.0 | 3.32.0 |
| `avo` | RubyGems | From 2.28.0 | 3.32.0 |

## How do I fix CVE-2026-53769?

Upgrade avo to 3.32.0 or later.

## Is CVE-2026-53769 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53769 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53769 and fix it if it is affected.

What it is: CVE-2026-53769 is a medium-severity missing authorization vulnerability in avo-hq avo, published on 4 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53769 exists.

Affected packages and fixed versions:
- avo (RubyGems): affected from 2.28.0; fixed in 3.32.0
- avo (RubyGems): affected from 2.28.0; fixed in 3.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53769/ (Markdown: https://insights.sbomify.com/CVE-2026-53769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53769
- OSV: https://osv.dev/vulnerability/CVE-2026-53769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53769/
Summaries are generated and may contain mistakes; the official description above is the record.
