# CVE-2026-53782: Summarize < 0.17.0 SSRF via podcast:transcript URL fetch


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-3vx2-vqx8-jxfg

## What is CVE-2026-53782?

CVE-2026-53782 is a medium-severity vulnerability in steipete summarize, published on 11 Jun 2026. 

### Official description

Summarize before 0.17.0 contains a server-side request forgery vulnerability that allows attackers who control a podcast RSS feed to direct the host to fetch transcript content from loopback addresses, link-local addresses, RFC 1918 private ranges, or other reserved destinations by supplying malicious podcast:transcript URL values. Attackers can bypass protections through DNS rebinding and redirect-based techniques, as redirect targets are not revalidated and hostnames are not resolved before request dispatch, exposing internal service responses through the summarization flow.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-53782?

2 open source packages ship an affected version, including @steipete/summarize.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@steipete/summarize` | npm | All versions | 0.17.0 |
| `@steipete/summarize` | npm | All versions | 0.17.0 |

## How do I fix CVE-2026-53782?

Upgrade @steipete/summarize to 0.17.0 or later.

## Is CVE-2026-53782 being exploited?

There is no known exploitation of CVE-2026-53782 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53782 and fix it if it is affected.

What it is: CVE-2026-53782 is a medium-severity vulnerability in steipete summarize, published on 11 Jun 2026. 
Exploitation: There is no known exploitation of CVE-2026-53782 in the wild and no public exploit code.

Affected packages and fixed versions:
- @steipete/summarize (npm): affected all versions; fixed in 0.17.0
- @steipete/summarize (npm): affected all versions; fixed in 0.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53782/ (Markdown: https://insights.sbomify.com/CVE-2026-53782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53782
- OSV: https://osv.dev/vulnerability/CVE-2026-53782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53782/
Summaries are generated and may contain mistakes; the official description above is the record.
