CVE-2026-53809 OpenClaw < 2026.4.25 - Provider Alias Confusion in Embedded Runner Policy
Attackers can bypass embedded runner policy restrictions by exploiting provider alias confusion to access bundled tools outside intended limits.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53809?
CVE-2026-53809 is a medium-severity vulnerability in Openclaw Openclaw, published on 11 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
OpenClaw before 2026.4.25 contains a policy bypass vulnerability in embedded runner policy that allows requests using provider aliases to compare against aliases instead of canonical provider identities. Attackers can exploit this confusion to select bundled tool access outside intended provider policy restrictions when the affected feature is enabled.
Weakness: CWE-863
Which versions are affected by CVE-2026-53809?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.4.25 |
openclaw npm | All versions | 2026.4.25 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-53809?
Upgrade openclaw to 2026.4.25 or later.
Is CVE-2026-53809 being exploited?
There is no known exploitation of CVE-2026-53809 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-p39j-x9h5-q66m, MINI-67p3-c7xv-hr5x.