CVE-2026-53821 OpenClaw < 2026.5.18 - Scope Elevation in trusted-proxy Control UI WebSocket
Unpaired or restricted clients can elevate privileges to admin scope via WebSocket, allowing execution of admin-gated RPCs.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53821?
CVE-2026-53821 is a high-severity vulnerability in Openclaw Openclaw, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.5.18 accepts WebSocket client-declared operator scopes before binding to server-approved pairing or trusted-proxy authorization baseline. Unpaired or restricted trusted-proxy Control UI clients can obtain cached operator.admin authority on live WebSocket connections to execute admin-gated Gateway RPCs.
Weakness: CWE-862
Which versions are affected by CVE-2026-53821?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.5.18 |
openclaw npm | All versions | 2026.5.18 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-53821?
Upgrade openclaw to 2026.5.18 or later.
Is CVE-2026-53821 being exploited?
There is no known exploitation of CVE-2026-53821 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-qjpc-qf9m-xwmr, GHSA-vcg8-6gf2-cg9j, MINI-f857-632r-jrwf, MINI-mpfw-xj8w-42h8.