CVE-2026-53848 OpenClaw < 2026.5.26 - Exec Allowlist Bypass via Transparent Command Wrappers
Authenticated attackers can bypass exec allowlists using transparent command wrappers to execute unintended operations in OpenClaw.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-53848?
CVE-2026-53848 is a low-severity vulnerability in Openclaw Openclaw, published on 16 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenClaw before 2026.5.26 contains an exec allowlist bypass vulnerability allowing authenticated operators to execute wrapper-level side effects outside allowlisted command intent. Attackers can craft command requests that bypass allowlist validation by leveraging transparent command wrappers to perform unintended operations.
Weakness: CWE-184
Which versions are affected by CVE-2026-53848?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.5.26 |
openclaw npm | All versions | 2026.5.26 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-53848?
Upgrade openclaw to 2026.5.26 or later.
Is CVE-2026-53848 being exploited?
There is no known exploitation of CVE-2026-53848 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-cwpp-5962-q4f6, MINI-53jv-qpm8-62cf.