# CVE-2026-53869: Hermes Agent < 0.16.0 - DNS Rebinding Bypass via WebSocket Endpoints

> Remote attackers can bypass Host and Origin validation via DNS rebinding on WebSocket endpoints to inject commands or read terminal output.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4pqm-j46f-795x, MINI-5mxq-6g44-4f87, MINI-87rj-p2hj-jhgm, MINI-vx7f-692v-4f7c, PYSEC-2026-2510

## What is CVE-2026-53869?

CVE-2026-53869 is a high-severity vulnerability in NousResearch hermes-agent, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hermes Agent before 0.16.0 contains a DNS rebinding vulnerability in WebSocket endpoints that allows remote attackers to bypass Host and Origin validation. FastAPI HTTP middleware does not execute for WebSocket upgrade requests on /api/pty, /api/ws, /api/pub, and /api/events endpoints, enabling attackers to exploit DNS rebinding and inject malicious commands or read terminal output.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-53869?

3 open source packages ship an affected version, including hermes-agent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hermes-agent` | PyPI | All versions | 0.16.0 |
| `hermes-agent` | PyPI | All versions | 0.16.0 |
| `hermes-agent` | PyPI | All versions | 0.16.0 |

## How do I fix CVE-2026-53869?

Upgrade hermes-agent to 0.16.0 or later.

## Is CVE-2026-53869 being exploited?

There is no known exploitation of CVE-2026-53869 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53869 and fix it if it is affected.

What it is: CVE-2026-53869 is a high-severity vulnerability in NousResearch hermes-agent, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53869 in the wild and no public exploit code.

Affected packages and fixed versions:
- hermes-agent (PyPI): affected all versions; fixed in 0.16.0
- hermes-agent (PyPI): affected all versions; fixed in 0.16.0
- hermes-agent (PyPI): affected all versions; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53869/ (Markdown: https://insights.sbomify.com/CVE-2026-53869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53869
- OSV: https://osv.dev/vulnerability/CVE-2026-53869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53869/
Summaries are generated and may contain mistakes; the official description above is the record.
