# CVE-2026-53870: Hermes Agent < 0.16.0 - Sensitive File Permission Vulnerability in Store Files

> Local attackers can read sensitive conversation history and HMAC secrets from Hermes Agent store files due to insecure file permissions.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-99f9-j8r3-p853, PYSEC-2026-2511

## What is CVE-2026-53870?

CVE-2026-53870 is a medium-severity vulnerability in NousResearch hermes-agent, published on 17 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Hermes Agent before 0.16.0 creates response_store.db and webhook_subscriptions.json with world-readable permissions (mode 0o644), exposing conversation history and HMAC secrets to local users. Attackers with local filesystem access can read these files directly to obtain sensitive data including conversation history, tool payloads, prompts, and per-route HMAC secrets.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2026-53870?

3 open source packages ship an affected version, including hermes-agent.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hermes-agent` | PyPI | All versions | 0.16.0 |
| `hermes-agent` | PyPI | All versions | 0.16.0 |
| `hermes-agent` | PyPI | All versions | 0.16.0 |

## How do I fix CVE-2026-53870?

Upgrade hermes-agent to 0.16.0 or later.

## Is CVE-2026-53870 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53870 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53870 and fix it if it is affected.

What it is: CVE-2026-53870 is a medium-severity vulnerability in NousResearch hermes-agent, published on 17 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53870 exists.

Affected packages and fixed versions:
- hermes-agent (PyPI): affected all versions; fixed in 0.16.0
- hermes-agent (PyPI): affected all versions; fixed in 0.16.0
- hermes-agent (PyPI): affected all versions; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53870/ (Markdown: https://insights.sbomify.com/CVE-2026-53870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53870
- OSV: https://osv.dev/vulnerability/CVE-2026-53870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53870/
Summaries are generated and may contain mistakes; the official description above is the record.
