# CVE-2026-53877: Heap buffer over-read in GDALRaster

> Heap buffer over-read in Django's GDALRaster allows attackers to disclose adjacent memory or cause denial of service via segmentation faults.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** BIT-django-2026-53877, DEBIAN-CVE-2026-53877, ECHO-540d-90d3-8a54, GHSA-crhf-3pfg-w68w, MINI-8j3x-3rvj-fqj7, MINI-f685-hq49-gf2m, PYSEC-2026-2091, UBUNTU-CVE-2026-53877

## What is CVE-2026-53877?

CVE-2026-53877 is a medium-severity vulnerability in Djangoproject Django, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Django 6.0 before 6.0.7 and 5.2 before 5.2.16.
`django.contrib.gis.gdal.GDALRaster` over-reads its in-memory buffer when constructed from a bytes object, which can disclose adjacent memory or cause service degradation via a potential segmentation fault when the `vsi_buffer` property is accessed.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Bence Nagy for reporting this issue.

Weakness: CWE-805 (Buffer Access with Incorrect Length Value)

## Which versions are affected by CVE-2026-53877?

6 open source packages ship an affected version, including django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 5.2.0 | 5.2.16, 6.0.7 |
| `django` | PyPI | All versions | 5.2.16 |
| `django` | PyPI | All versions | 5.2.16 |
| `django` | PyPI | From 5.2 | 5.2.16, 6.0.7 |
| `django` | PyPI | From 6.0.0 | 6.0.7 |
| `django` | PyPI | From 6.0.0 | 6.0.7 |

Products: Djangoproject Django.

## How do I fix CVE-2026-53877?

Upgrade django to a fixed version for your release line: 5.2.16 or 6.0.7.

## Is CVE-2026-53877 being exploited?

There is no known exploitation of CVE-2026-53877 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53877 and fix it if it is affected.

What it is: CVE-2026-53877 is a medium-severity vulnerability in Djangoproject Django, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53877 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 5.2.0; fixed in 5.2.16, 6.0.7
- django (PyPI): affected all versions; fixed in 5.2.16
- django (PyPI): affected all versions; fixed in 5.2.16
- django (PyPI): affected from 5.2; fixed in 5.2.16, 6.0.7
- django (PyPI): affected from 6.0.0; fixed in 6.0.7
- django (PyPI): affected from 6.0.0; fixed in 6.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53877/ (Markdown: https://insights.sbomify.com/CVE-2026-53877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53877
- OSV: https://osv.dev/vulnerability/CVE-2026-53877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53877/
Summaries are generated and may contain mistakes; the official description above is the record.
