# CVE-2026-5389: justhtml before 1.13.0 XSS via code fence breakout

> Attackers can inject raw HTML into sanitized content via code fence breakout, leading to XSS when rendered by Markdown parsers.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 23 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** GHSA-5vp3-3cg6-2rq3, GHSA-q3jf-9wv7-p29w

## What is CVE-2026-5389?

CVE-2026-5389 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

justhtml versions before 1.13.0 contain a cross-site scripting vulnerability in the to_markdown() function when serializing attacker-controlled pre content. Attackers can place backticks inside sanitized pre elements to break out of fixed-length code fences, allowing raw HTML to execute when the generated Markdown is rendered by CommonMark or GFM-style renderers.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-5389?

2 open source packages ship an affected version, including justhtml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `justhtml` | PyPI | All versions | 1.13.0 |
| `justhtml` | PyPI | All versions | 1.13.0 |

## How do I fix CVE-2026-5389?

Upgrade justhtml to 1.13.0 or later.

## Is CVE-2026-5389 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5389 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5389 and fix it if it is affected.

What it is: CVE-2026-5389 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-5389 exists.

Affected packages and fixed versions:
- justhtml (PyPI): affected all versions; fixed in 1.13.0
- justhtml (PyPI): affected all versions; fixed in 1.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5389/ (Markdown: https://insights.sbomify.com/CVE-2026-5389/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5389
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5389
- OSV: https://osv.dev/vulnerability/CVE-2026-5389

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5389/
Summaries are generated and may contain mistakes; the official description above is the record.
