# CVE-2026-53916: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: Unbounded header buffer in STOMP NIO codec

> Unauthenticated attackers can exhaust JVM heap memory by sending unterminated STOMP headers, causing denial of service in Apache ActiveMQ.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** BIT-activemq-2026-53916, DEBIAN-CVE-2026-53916, GHSA-2q9g-8573-3265, MINI-4wvx-3r7c-pchf, MINI-gc94-x82x-fcwm, MINI-hwfm-2gpg-r56p, MINI-p5g6-hpp8-r5xp, UBUNTU-CVE-2026-53916

## What is CVE-2026-53916?

CVE-2026-53916 is a high-severity denial of service vulnerability in Apache Activemq, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp.

An unauthenticated client that opens a STOMP NIO connection can send header bytes that never terminate which makes the broker buffer them without limit, exhausting the JVM heap. 
This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-53916?

1 open source package ship an affected version, including activemq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activemq` | Bitnami | All versions | 5.19.8, 6.2.7 |

Products: Apache Activemq.

## How do I fix CVE-2026-53916?

Upgrade activemq to a fixed version for your release line: 5.19.8 or 6.2.7.

## Is CVE-2026-53916 being exploited?

There is no known exploitation of CVE-2026-53916 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53916 and fix it if it is affected.

What it is: CVE-2026-53916 is a high-severity denial of service vulnerability in Apache Activemq, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53916 in the wild and no public exploit code.

Affected packages and fixed versions:
- activemq (Bitnami): affected all versions; fixed in 5.19.8, 6.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53916/ (Markdown: https://insights.sbomify.com/CVE-2026-53916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53916
- OSV: https://osv.dev/vulnerability/CVE-2026-53916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53916/
Summaries are generated and may contain mistakes; the official description above is the record.
