CVE-2026-53917 Denial of service in Apache ActiveMQ

High 7.5 Published Updated

An authenticated user can crash the Apache ActiveMQ broker by sending a crafted OpenWire message with an excessive size value, causing an out-of-memory error.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-53917?

CVE-2026-53917 is a high-severity denial of service vulnerability in Apache Activemq, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker.

An authenticated user can cause a broker DoS by sending a crafted OpenWire Message with a large encoded size value for the map. OpenWire message property maps are unmarshaled without size validation which can trigger OOM and crash the broker. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Client: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

Weakness: CWE-789

Which versions are affected by CVE-2026-53917?

1 open source package ship an affected version, including activemq. It affects 2 products.

PackageAffectedFixed in
activemq BitnamiAll versions5.19.8, 6.2.7

Products include Apache Activemq, Apache Activemq Broker.

How do I fix CVE-2026-53917?

Upgrade activemq to a fixed version for your release line: 5.19.8 or 6.2.7.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-53917 being exploited?

There is no known exploitation of CVE-2026-53917 in the wild and no public exploit code.

All Apache Activemq vulnerabilities

Sources

Also known as BIT-activemq-2026-53917, DEBIAN-CVE-2026-53917, GHSA-f77w-px59-cqf5, MINI-246x-qc9h-22pf, MINI-5jhx-3m23-m667, MINI-6gh8-prhx-9m8j and 2 more.

Is CVE-2026-53917 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free