{"answers":{"affected":"1 open source package ship an affected version, including activemq. It affects 2 products.","exploited":"There is no known exploitation of CVE-2026-53917 in the wild and no public exploit code.","fix":"Upgrade activemq to a fixed version for your release line: 5.19.8 or 6.2.7.","what":"CVE-2026-53917 is a high-severity denial of service vulnerability in Apache Activemq, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-53917 and fix it if it is affected.\n\nWhat it is: CVE-2026-53917 is a high-severity denial of service vulnerability in Apache Activemq, published on 30 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-53917 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- activemq (Bitnami): affected all versions; fixed in 5.19.8, 6.2.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-53917/ (Markdown: https://insights.sbomify.com/CVE-2026-53917/index.md)","id":"CVE-2026-53917","markdown":"https://insights.sbomify.com/CVE-2026-53917/index.md","name":"CVE-2026-53917","record":{"aliases":["BIT-activemq-2026-53917","DEBIAN-CVE-2026-53917","GHSA-f77w-px59-cqf5","MINI-246x-qc9h-22pf","MINI-5jhx-3m23-m667","MINI-6gh8-prhx-9m8j","MINI-v3vm-4rg2-vprv","UBUNTU-CVE-2026-53917"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ Broker","requires_auth":"none","summary":"An authenticated user can crash the Apache ActiveMQ broker by sending a crafted OpenWire message with an excessive size value, causing an out-of-memory error.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"activemq","vendor":"apache"},{"product":"activemq_broker","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-789","name":"Memory Allocation with Excessive Size Value"}],"description":"Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Client, Apache ActiveMQ Broker.\n\nAn authenticated user can cause a broker DoS by sending a crafted OpenWire Message with a large encoded size value for the map. OpenWire message property maps are unmarshaled without size validation which can trigger OOM and crash the broker.\nThis issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Client: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7.\n\nUsers are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in Apache ActiveMQ","id":"CVE-2026-53917","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:activemq","products":["apache:activemq"],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"odhcpd DHCPv6 IA dangling first pointer use-after-free","id":"CVE-2026-53918"},"packages":[{"ecosystem":"Bitnami","fixed":["5.19.8","6.2.7"],"introduced":["0","6.0.0"],"last_affected":[],"package":"activemq","purl":"pkg:bitnami/activemq","source":"BIT-activemq-2026-53917"}],"prev":{"headline":"Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: Unbounded header buffer in STOMP NIO codec","id":"CVE-2026-53916"},"products":["Apache ActiveMQ","Apache ActiveMQ All","Apache ActiveMQ Broker","Apache ActiveMQ Client"],"published":"2026-06-30","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"},{"cvss_score":9.8,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","kev_date_added":null,"published":"2016-01-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-30","vendors":["Apache Software Foundation"]},"summary":"An authenticated user can crash the Apache ActiveMQ broker by sending a crafted OpenWire message with an excessive size value, causing an out-of-memory error.","url":"https://insights.sbomify.com/CVE-2026-53917/"}