# CVE-2026-53918: odhcpd DHCPv6 IA dangling first pointer use-after-free


- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-44ff-jcwh-wgc2

## What is CVE-2026-53918?

CVE-2026-53918 is a high-severity vulnerability in openwrt odhcpd, published on 23 Oct 2026. 

### Official description

odhcpd is the DHCPv6, DHCPv4, and router-advertisement server used by OpenWrt. Prior to version 25.12, odhcpd's DHCPv6 IA handler keeps a per-message `first` lease pointer so multiple IA options in one message reuse the same Reconfigure authentication key. A DHCPv6 REQUEST from an adjacent-network client can make the first IA set `first`, then make a later same-IAID IA fail the on-link check and free that same lease, leaving `first` dangling. A following IA in the same packet allocates a new lease and copies `first->key`, producing a 16-byte heap-use-after-free read. ASan confirms the UAF; native tracing shows the packet shape can deterministically reclaim the freed lease as the destination allocation, producing a zeroed Reconfigure key copy. The validated impact is unauthenticated adjacent-network denial of service and DHCPv6 Reconfigure/ForceRenew key confusion. Arbitrary PC control is not proven for this UAF alone. This issue has been patched in version 25.12.

Weakness: CWE-825 (Expired Pointer Dereference), CWE-672 (Operation on a Resource after Expiration or Release), CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-53918?


## How do I fix CVE-2026-53918?

No fix has been published for CVE-2026-53918 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53918 being exploited?

There is no known exploitation of CVE-2026-53918 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53918 and fix it if it is affected.

What it is: CVE-2026-53918 is a high-severity vulnerability in openwrt odhcpd, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-53918 in the wild and no public exploit code.

Affected product: openwrt odhcpd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53918/ (Markdown: https://insights.sbomify.com/CVE-2026-53918/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53918
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53918
- OSV: https://osv.dev/vulnerability/CVE-2026-53918

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53918/
Summaries are generated and may contain mistakes; the official description above is the record.
