# CVE-2026-53921: odhcpd: Stack buffer overflow in DHCPv6 IA reply serialization (2 independent sites)


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-7fwx-hhrg-3496

## What is CVE-2026-53921?

CVE-2026-53921 is a critical vulnerability in openwrt odhcpd, published on 23 Oct 2026. 

### Official description

odhcpd is the DHCPv6, DHCPv4, and router-advertisement server used by OpenWrt. Prior to version 25.12, odhcpd's DHCPv6 IA response handler writes past the end of a fixed 512-byte stack buffer (pdbuf) when a single DHCPv6 REQUEST carries enough IA options to nearly exhaust the reply space. Two independent overflow sites exist in the same call chain, both reachable from the network via a single unauthenticated UDP packet. odhcpd runs as root on OpenWrt; embedded targets often lack stack canaries and ASLR, making code execution realistic. This issue has been patched in version 25.12.

Weakness: CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2026-53921?


## How do I fix CVE-2026-53921?

No fix has been published for CVE-2026-53921 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53921 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53921 exists.

Public exploit code:

- CVE-2026-53921 – odhcpd Stack Overflow (CVSS 9.8)  Vuln detailed and comprehensive Write-Up and Verifier & Multi-exploit for OpenWrt DHCPv6 RCE. Dual-vector (IA_NA/IA_PD) overflow with MIPS/ARM shellcode, ROP chains, SOCKS5 proxy, persistence, log wiping & mass scanning. Use Ethically, Stay Legal. (github_poc): https://github.com/tc4dy/CVE-2026-53921-PoC-Exploit
- CVE-2026-53921 (github_poc): https://github.com/0xredash/CVE-2026-53921
- Offline Python source-pattern auditor for CVE-2026-53921 in odhcpd. (github_poc): https://github.com/mehmet-emir-eroglu/CVE-2026-53921

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53921 and fix it if it is affected.

What it is: CVE-2026-53921 is a critical vulnerability in openwrt odhcpd, published on 23 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-53921 exists.

Affected product: openwrt odhcpd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53921/ (Markdown: https://insights.sbomify.com/CVE-2026-53921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53921
- OSV: https://osv.dev/vulnerability/CVE-2026-53921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53921/
Summaries are generated and may contain mistakes; the official description above is the record.
