CVE-2026-53923 vLLM GGUF Kernels: int64_t to int truncation of tensor dimensions causes GPU buffer overflow
Integer truncation in vLLM GGUF kernels leaves uninitialized GPU memory, potentially exposing other users' tensor data in multi-tenant deployments.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-53923?
CVE-2026-53923 is a medium-severity vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
vLLM is an inference and serving engine for large language models (LLMs). From 0.5.5 until 0.23.1rc0, integer truncation of tensor dimensions in vLLM's GGUF dequantize kernels (csrc/quantization/gguf/gguf_kernel.cu) causes partial tensor processing. The output tensor is allocated at full size via torch::empty (uninitialized memory), but the dequantize CUDA kernel processes only a truncated number of elements. The unfilled portion of the output tensor retains whatever was previously in GPU memory. In multi-tenant inference deployments, this residual GPU memory may contain tensor data from other users' inference requests, constituting information disclosure. This vulnerability is fixed in 0.23.1rc0.
Which versions are affected by CVE-2026-53923?
3 open source packages ship an affected version, including vllm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vllm PyPI | From 0.5.5 to 0.23.0 | None |
vllm PyPI | From 0.5.5 | 0.24.0 |
vllm PyPI | From 0.5.5 | 0.24.0 |
Products include Vllm Vllm.
How do I fix CVE-2026-53923?
Upgrade vllm to 0.24.0 or later.
Is CVE-2026-53923 being exploited?
There is no known exploitation of CVE-2026-53923 in the wild and no public exploit code.
Other vulnerabilities in Vllm Vllm
- CVE-2025-32444 vLLM Vulnerable to Remote Code Execution via Mooncake Integration
- CVE-2026-22778 vLLM leaks a heap address when PIL throws an error
- CVE-2025-47277 vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
- CVE-2024-11041 Remote Code Execution in vllm-project/vllm
- CVE-2026-48746 vLLM: OpenAI auth bypass
Sources
Also known as GHSA-5jv2-g5wq-cmr4, MINI-f56m-6pf7-hj95, MINI-qv8g-w4fh-gcw6, MINI-xv25-w852-h85p, PYSEC-2026-3403.