# CVE-2026-53923: vLLM GGUF Kernels: int64_t to int truncation of tensor dimensions causes GPU buffer overflow

> Integer truncation in vLLM GGUF kernels leaves uninitialized GPU memory, potentially exposing other users' tensor data in multi-tenant deployments.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** GHSA-5jv2-g5wq-cmr4, MINI-f56m-6pf7-hj95, MINI-qv8g-w4fh-gcw6, MINI-xv25-w852-h85p, PYSEC-2026-3403

## What is CVE-2026-53923?

CVE-2026-53923 is a medium-severity vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.5.5 until 0.23.1rc0, integer truncation of tensor dimensions in vLLM's GGUF dequantize kernels (csrc/quantization/gguf/gguf_kernel.cu) causes partial tensor processing. The output tensor is allocated at full size via torch::empty (uninitialized memory), but the dequantize CUDA kernel processes only a truncated number of elements. The unfilled portion of the output tensor retains whatever was previously in GPU memory. In multi-tenant inference deployments, this residual GPU memory may contain tensor data from other users' inference requests, constituting information disclosure. This vulnerability is fixed in 0.23.1rc0.

Weakness: CWE-681 (Incorrect Conversion between Numeric Types), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-53923?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.5.5 to 0.23.0 | None |
| `vllm` | PyPI | From 0.5.5 | 0.24.0 |
| `vllm` | PyPI | From 0.5.5 | 0.24.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-53923?

Upgrade vllm to 0.24.0 or later.

## Is CVE-2026-53923 being exploited?

There is no known exploitation of CVE-2026-53923 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53923 and fix it if it is affected.

What it is: CVE-2026-53923 is a medium-severity vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-53923 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.5.5 up to 0.23.0; no fix listed
- vllm (PyPI): affected from 0.5.5; fixed in 0.24.0
- vllm (PyPI): affected from 0.5.5; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53923/ (Markdown: https://insights.sbomify.com/CVE-2026-53923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53923
- OSV: https://osv.dev/vulnerability/CVE-2026-53923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53923/
Summaries are generated and may contain mistakes; the official description above is the record.
