# CVE-2026-53929: NocoDB: Stored Cross-Site Scripting via Secure Attachment

> Authenticated users can execute arbitrary scripts via malicious HTML or SVG attachments when secure attachments are enabled, due to header key mismatches.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 23 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-6mhr-74x2-98v9

## What is CVE-2026-53929?

CVE-2026-53929 is a medium-severity cross-site scripting vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.05.1, with NC_SECURE_ATTACHMENTS=true, an authenticated uploader could deliver .html or .svg attachments that the browser rendered inline from the NocoDB origin instead of forcing a download. The signed attachment handler stored response-header overrides under PascalCase keys (ResponseContentDisposition, ResponseContentType) while the controller that served the file read them under lowercase-hyphen names (response-content-disposition). The mismatch dropped the Content-Disposition: attachment header, leaving Express to auto-render .html, .svg, and similar inline. This vulnerability is fixed in 2026.05.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-53929?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions to 0.301.3 | None |
| `nocodb` | npm | All versions to 0.301.3 | None |

## How do I fix CVE-2026-53929?

No fix has been published for CVE-2026-53929 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53929 being exploited?

There is no known exploitation of CVE-2026-53929 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53929 and fix it if it is affected.

What it is: CVE-2026-53929 is a medium-severity cross-site scripting vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-53929 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions up to 0.301.3; no fix listed
- nocodb (npm): affected all versions up to 0.301.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53929/ (Markdown: https://insights.sbomify.com/CVE-2026-53929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53929
- OSV: https://osv.dev/vulnerability/CVE-2026-53929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53929/
Summaries are generated and may contain mistakes; the official description above is the record.
