# CVE-2026-53931: NocoDB: Server-Side Request Forgery via Spreadsheet Import Endpoint

> Unauthenticated attackers can exploit a flawed URL validation in the spreadsheet import endpoint to perform Server-Side Request Forgery, potentially accessing internal resources.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-hmcr-rmjq-47qr

## What is CVE-2026-53931?

CVE-2026-53931 is a medium-severity server-side request forgery vulnerability in nocodb, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.05.1, the spreadsheet-import endpoint axiosRequestMake could be used as a generic HTTP proxy. Before the fix it was reachable unauthenticated, and its URL-extension allowlist was a regex tested against the full URL string, so URLs whose query string ended in .csv satisfies the gate even though the
underlying request is for another file. This vulnerability is fixed in 2026.05.1.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2026-53931?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions to 0.301.3 | None |
| `nocodb` | npm | All versions to 0.301.3 | None |

## How do I fix CVE-2026-53931?

No fix has been published for CVE-2026-53931 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-53931 being exploited?

There is no known exploitation of CVE-2026-53931 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53931 and fix it if it is affected.

What it is: CVE-2026-53931 is a medium-severity server-side request forgery vulnerability in nocodb, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53931 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions up to 0.301.3; no fix listed
- nocodb (npm): affected all versions up to 0.301.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53931/ (Markdown: https://insights.sbomify.com/CVE-2026-53931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53931
- OSV: https://osv.dev/vulnerability/CVE-2026-53931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53931/
Summaries are generated and may contain mistakes; the official description above is the record.
