# CVE-2026-53935: CiliumLocalRedirectPolicy addressMatcher allows cross-namespace service traffic hijacking and can break service translation

> Users with policy creation rights can hijack cross-namespace service traffic or disrupt service translation by specifying arbitrary ClusterIPs in CiliumLocalRedirectPolicies.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** BIT-cilium-2026-53935, BIT-cilium-operator-2026-53935, BIT-hubble-relay-2026-53935, GHSA-q6h5-q3q6-f87x, GO-2026-5914, MINI-2cx6-r5r6-w4j5, MINI-2wx8-jr4j-j7cr, MINI-2x2f-xhrx-76mm, MINI-342q-3f8j-hc6c, MINI-4q44-cv7v-cj88, MINI-568c-r5rc-c6q9, MINI-5x88-jcc9-8hjq, MINI-636m-3c6f-43xc, MINI-68gg-2q7w-5hw8, MINI-7p7m-chcg-254g, MINI-7r36-p3p6-f9j8, MINI-7w4f-vv55-m4pm, MINI-8rqg-vhvg-wq2v, MINI-8v2r-rj32-xjpm, MINI-9gf8-p466-69fg, MINI-9v3v-2hff-3p7c, MINI-ggpg-j7v6-qxc8, MINI-gm5j-9923-f5c4, MINI-gxr5-vfv8-f9f2, MINI-h9v7-99hq-538h, MINI-j227-q669-crm6, MINI-mhhv-mpw3-v9cg, MINI-mm49-9x9c-pp2w, MINI-q7pv-rxrx-9qhw, MINI-rffx-rg8m-5pjr, MINI-w9hh-hh6m-9794, MINI-wmgm-6f93-f4m4, MINI-xp4j-695q-pcwg

## What is CVE-2026-53935?

CVE-2026-53935 is a medium-severity missing authorization vulnerability in cilium, published on 7 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution. Prior to 1.17.16, from 1.18.2 to 1.18.9, and from 1.19.0 to 1.19.3, users with the ability to create CiliumLocalRedirectPolicies can specify arbitrary ClusterIPs via addressMatcher, enabling hijacking traffic to Services in any namespace and bypassing namespace scoping enforced by serviceMatcher; deleting such a policy can also corrupt Cilium internal service state and stop service translation for the affected Service. This issue is fixed in versions 1.17.16, 1.18.10, and 1.19.4.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-53935?

10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | All versions | 1.17.16, 1.18.10, 1.19.4 |
| `github.com/cilium/cilium` | Go | All versions | 1.17.16 |
| `github.com/cilium/cilium` | Go | All versions | 1.17.16 |
| `github.com/cilium/cilium` | Go | From 1.18.2 | 1.18.10 |
| `github.com/cilium/cilium` | Go | From 1.18.2 | 1.18.10 |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.4 |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.4 |
| `cilium` | Bitnami | All versions | 1.17.16, 1.18.10, 1.19.4 |
| `cilium-operator` | Bitnami | All versions | 1.17.16, 1.18.10, 1.19.4 |
| `hubble-relay` | Bitnami | All versions | 1.17.16, 1.18.10, 1.19.4 |

## How do I fix CVE-2026-53935?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.17.16, 1.18.10 or 1.19.4.

## Is CVE-2026-53935 being exploited?

There is no known exploitation of CVE-2026-53935 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-53935 and fix it if it is affected.

What it is: CVE-2026-53935 is a medium-severity missing authorization vulnerability in cilium, published on 7 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-53935 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.16, 1.18.10, 1.19.4
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.16
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.16
- github.com/cilium/cilium (Go): affected from 1.18.2; fixed in 1.18.10
- github.com/cilium/cilium (Go): affected from 1.18.2; fixed in 1.18.10
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.4
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.4
- cilium (Bitnami): affected all versions; fixed in 1.17.16, 1.18.10, 1.19.4
- cilium-operator (Bitnami): affected all versions; fixed in 1.17.16, 1.18.10, 1.19.4
- hubble-relay (Bitnami): affected all versions; fixed in 1.17.16, 1.18.10, 1.19.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-53935/ (Markdown: https://insights.sbomify.com/CVE-2026-53935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-53935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-53935
- OSV: https://osv.dev/vulnerability/CVE-2026-53935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-53935/
Summaries are generated and may contain mistakes; the official description above is the record.
